












	
		
	
	
		
	
	
	
	


<!DOCTYPE html>
<!--[if lt IE 7]>  <html lang="en" class="lt-ie9 lt-ie8 lt-ie7" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 7]> <html lang="en" class="lt-ie10 lt-ie9 lt-ie8" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 8]> <html lang="en" class="lt-ie10 lt-ie9" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 9]> <html lang="en" class="lt-ie10" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <!--<![endif]-->
	
	











<head>
	<link rel="alternate" hreflang="en" href="https://www.computerworld.com/article/3566143/microsoft-android-transformation.html" />
	
	
	
	<!-- metas -->
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" />
	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />		
	<title>The Microsoft-Android transformation is about to affect us all | Computerworld</title>
	
	
			
			
			    <meta name="viewport" content="width=device-width, initial-scale=1.0">
         	
	
	
	
	<script>
	function getQueryVariable(variable) {
		var query = window.location.search.substring(1);
		var vars = query.split("&");
		for (var i=0;i<vars.length;i++) {
			var pair = vars[i].split("=");
			if(pair[0] == variable){return pair[1];}
		}
		return(false);
	}
	</script>
	
	<script>
	// Include CSS file for insider modal - used in insider_reg_api.js
	function addCSS(filename){
		 var headerTag = document.querySelector("header#banner");
		 var styleTag = document.createElement('link');
		 styleTag.href = filename;
		 styleTag.className = "oc-modal";
		 styleTag.type = 'text/css';
		 styleTag.rel = 'stylesheet';
		 headerTag.parentNode.insertBefore(styleTag, headerTag);
	}
	function addScript(filename){
		let headTag = document.querySelector("header#banner");
		let scriptTag = document.createElement('script');
		scriptTag.src = filename;
		scriptTag.className = 'oc-modal';
		scriptTag.type = 'text/javascript';
		headTag.parentNode.insertBefore(scriptTag, headTag);
	}
	</script>
		
	<!-- ad-related js -->
	<script src="/www/js/jquery/jquery-1.10.2.min.js"></script>
	
	<script type="text/javascript" src="/www/js/jquery/jquery_cookie.js"></script>
	
	
	
	<script type="text/javascript" src="/www/js/apollo-locales.js?v=20200708115223"></script>
	
	
	











<script src="//d2zv5rkii46miq.cloudfront.net/0/latest/cmp_shim.js"></script>

<script>
var consent = consent || {};
consent.isEU = consent.isEU || null;
consent.personalization = consent.personalization || null;
consent.ads = consent.ads || {};
consent.ads.queue = consent.ads.queue || [];

consent.infostorage = consent.infostorage || {};
consent.infostorage.queue = consent.infostorage.queue || [];

consent.adsel = consent.adsel || {};
consent.adsel.queue = consent.adsel.queue || [];

consent.contentsel = consent.contentsel || {};
consent.contentsel.queue = consent.contentsel.queue || [];

consent.socmedia = consent.socmedia || {};
consent.socmedia.queue = consent.socmedia.queue || [];

consent.blueconic = consent.blueconic || {};
consent.blueconic.queue = consent.blueconic.queue || [];

consent.digitalelement = consent.digitalelement || {};
consent.digitalelement.queue = consent.digitalelement.queue || [];

consent.purposes = consent.purposes || {};
consent.purposes.standard = consent.purposes.standard || [];
consent.purposes.custom = consent.purposes.custom || [];
consent.vendors = consent.vendors || {};
consent.vendors.standard = consent.vendors.standard || [];
consent.vendors.custom = consent.vendors.custom || [];

var dataLayer = window.dataLayer = window.dataLayer || [];
</script>






<style type="text/css">
#sp_privacy_manager_container {
	z-index: 10000000 !important;
}
</style>

<script> 											
window._sp_ = window._sp_ || {};
window._sp_.config = window._sp_.config || {};

//Replace YOUR_ACCOUNT_ID with the account ID provided
//by Sourcepoint
window._sp_.config.account_id = 146;

// replace 'mms.sp-prod.net' with your CNAME'd messaging subdomain		
window._sp_.config.mms_domain = 'cmp.computerworld.com' ; 
//window._sp_.config.mms_domain = 'mms.sp-prod.net' ; 

// messaging-specific configuration
window._sp_.mms = window._sp_.mms || {};
window._sp_.mms.cmd = window._sp_.mms.cmd || [];

//CMP Flags
window._sp_.config.cmp = _sp_.config.cmp || {};
window._sp_.config.cmp.enabled = true;
window._sp_.config.cmp.waitForConsentData = true;

//Code to call the server and display a message
window._sp_.mms.cmd.push( function () {
    window._sp_.mms.startMsg();
});
</script>

<script src="/www/js/messaging.js?v=dec2019update"></script>


<script type="text/javascript">(function () { var e = false; var c = window; var t = document; function r() { if (!c.frames["__uspapiLocator"]) { if (t.body) { var a = t.body; var e = t.createElement("iframe"); e.style.cssText = "display:none"; e.name = "__uspapiLocator"; a.appendChild(e) } else { setTimeout(r, 5) } } } r(); function p() { var a = arguments; __uspapi.a = __uspapi.a || []; if (!a.length) { return __uspapi.a } else if (a[0] === "ping") { a[2]({ gdprAppliesGlobally: e, cmpLoaded: false }, true) } else { __uspapi.a.push([].slice.apply(a)) } } function l(t) { var r = typeof t.data === "string"; try { var a = r ? JSON.parse(t.data) : t.data; if (a.__cmpCall) { var n = a.__cmpCall; c.__uspapi(n.command, n.parameter, function (a, e) { var c = { __cmpReturn: { returnValue: a, success: e, callId: n.callId } }; t.source.postMessage(r ? JSON.stringify(c) : c, "*") }) } } catch (a) { } } if (typeof __uspapi !== "function") { c.__uspapi = p; __uspapi.msgHandler = l; c.addEventListener("message", l, false) } })();</script>
<script>
        window._sp_ccpa = {
            config: {
                mmsDomain: "https://cmp.computerworld.com",
                ccpaOrigin: "https://ccpa-service.sp-prod.net",
                accountId: "146",
                getDnsMsgMms: true,
                alwaysDisplayDns: false,
            }
        }
</script>
<script src="https://ccpa.sp-prod.net/ccpa.js"></script>

<script>
__cmp('getConsentData',null,function(e){
	
	consent.isEU = e.gdprApplies;
	if (!consent.isEU) {
		
		
		consent.personalization=false;
		
		__uspapi('getUSPData', 1, (uspData, success) => {
			if(success) {
				try {
					console.log('uspapi success: ', uspData);
					var uspDataString = uspData.uspString;
					var uspDataArray = [];
					uspDataArray = uspDataString.split("");
					if (typeof uspDataArray[2] !== "undefined" && uspDataArray[2] !== "Y") {
						console.log('User has not opted in to CCPA - run everything');
						consent.personalization=true;
						$(window).trigger("runConsent", [consent.socmedia.queue]);
						$(window).trigger("runConsent", [consent.blueconic.queue]);
					}
		
					$(window).trigger("runConsent", [consent.adsel.queue]);
				}
				catch(e) {
					console.log('error with uspData retrieval: ', e);
				}
				
			} else {
				console.log('uspapi fail: ', uspData);
			}
			
		});	
		
		$(window).trigger("runConsent", [consent.contentsel.queue]);
		$(window).trigger("runConsent", [consent.digitalelement.queue]);
		$(window).trigger("runConsent", [consent.ads.queue]);
		$(window).trigger("runConsent", [consent.infostorage.queue]);
		
	
		dataLayer.push({
			'event': 'consentKnown' 
		});
		bindReshowCmp();
	}
	else if (e.consentData !== null && e.consentData !== "") { // else if.. visitor is from EU and consent is known...
		getConsentInfo();
		bindReshowCmp();
	}
	else { //else consent is not known
	    bindReshowCmp();
	}
});

function getConsentInfo() {
	
	__cmp('getVendorConsents',[],function (e) {
		
		consent.purposes.standard = Object.keys(e.purposeConsents);
		consent.vendors.standard = Object.keys(e.vendorConsents);
		
		consent.personalization = consent.purposes.standard.includes("2");
		
		
		
		
		
		
		
		if (consent.purposes.standard.includes("1")) { // if information storage consent is TRUE run queue
			
			$(window).trigger("runConsent", [consent.infostorage.queue]);
		}
		if (consent.purposes.standard.includes("3")) { // if ad selection consent is TRUE run queue
			
			$(window).trigger("runConsent", [consent.adsel.queue]);
		}
		if (consent.purposes.standard.includes("4")) { // if content selection consent is TRUE run queue
			
			$(window).trigger("runConsent", [consent.contentsel.queue]);
		}
		//special case for blueconic
		if (consent.purposes.standard.includes("1") && consent.purposes.standard.includes("2") && consent.purposes.standard.includes("3") && consent.purposes.standard.includes("4") && consent.purposes.standard.includes("5")) {
			
			$(window).trigger("runConsent", [consent.blueconic.queue]);
		}
		
		//special case for Digital Element
		if (consent.purposes.standard.includes("2") && consent.purposes.standard.includes("3") && consent.purposes.standard.includes("4") && consent.purposes.standard.includes("5")) {
			
			$(window).trigger("runConsent", [consent.digitalelement.queue]);
		}
	});

	__cmp('getCustomVendorConsents',[],function (e) { 
		
		consent.purposes.custom = [];
		e.consentedPurposes.forEach(function(item, index) {
			consent.purposes.custom.push(item.name);
		});
		
		consent.vendors.custom = [];
		e.consentedVendors.forEach(function(item, index) {
			consent.vendors.custom.push(item.name);
		});
		
		
		
		if (consent.purposes.custom.includes("Social Media Consents")) { // if social media consent is TRUE run queue
			
			$(window).trigger("runConsent", [consent.socmedia.queue]);
		}
		
		
		if (consent.vendors.custom.includes("Google Ad Manager")) {
			
			$(window).trigger("runConsent", [consent.ads.queue]);
		}
		
	});
	
	dataLayer.push({
		'event': 'consentKnown' 
	});
}

var idgCMPSourcepointCallback = function(){
	if (consent.isEU) {		
		getConsentInfo();
	}
}

$(window).on("runConsent", function(event, queueToRun) {
		watchConsentQueue(queueToRun)
});

function runQueue(queue){
	for (var x=0;x<queue.length;x++) {
		var nextFn = queue.shift();
		nextFn();
		
	}	
}

function watchConsentQueue(queue){
	setInterval(function() { runQueue(queue); },500);
}
function bindReshowCmp() {
	var url = document.location.pathname;
	if (url.indexOf("/about/member-preferences") > -1) {
		$(document).ready(function() {
			$(".cmpSettings").show();
			$(".reshowLink").on("click", function(e) {
				e.preventDefault();
				window._sp_.privacyManager.loadPrivacyManagerModal(3919, '5cd195e5f9f3332a80a0e25f');
			});
		});
	}
}
</script>




	
	
		











<script>
consent.blueconic.queue.push(function(){
	var bcscript = document.createElement("script");
	bcscript.async = true;
	bcscript.type = "text/javascript";
    var useSSL = "https:" == document.location.protocol;
    bcscript.src = (useSSL ? "https:" : "http:") + "//cdn.blueconic.net/idg.js";
    var node=document.getElementsByTagName("script")[0];
    node.parentNode.insertBefore(bcscript, node);
});
</script>
	
	
	
		










<script>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</script>

	
	
	
	<script src="/www/js/init_device.js"></script>
	
	

	

	
		
			
			



















	<script async="async" src="//cdn.adsafeprotected.com/iasPET.1.js"></script>




	<script async src="//js-sec.indexww.com/ht/p/183980-32335169869501.js"></script>

	
<script type="text/javascript" src="/www/js/ads/gpt_includes.js?v=20200708115223"></script>


	












<script>

function refreshCountdown(slotName) {
	IDG.GPT.log(slotName + " refresh countdown: " + IDG.GPT.refreshCountdown[slotName].timeRemaining);
	IDG.GPT.refreshCountdown[slotName].timeRemaining -= 1;
	
	if (IDG.GPT.refreshCountdown[slotName].timeRemaining == 0) {
		clearInterval(IDG.GPT.refreshCountdown[slotName].interval);
		IDG.GPT.log(slotName + ' - time to refresh ad!');
		
		//perform ad refresh
		IDG.GPT.refreshAd(slotName);		
	}
}

var refreshInterval = 30;

var testRefreshInterval = IDG.GPT.getUrlParameter("interval");
if (typeof testRefreshInterval !== "undefined" && typeof parseInt(testRefreshInterval) === "number") {
	refreshInterval = parseInt(testRefreshInterval);
}

IDG.GPT.log("Ad refreshing ON - every " + refreshInterval + " seconds");

IDG.GPT.viewable = {};
IDG.GPT.visibility = {};
IDG.GPT.refreshCountdown = {};

IDG.GPT.impressionViewable = function (){
	googletag.pubads().addEventListener('impressionViewable', function (event) {
		var currentSlot = event.slot.getSlotElementId();
		if (currentSlot !== 'inread' && currentSlot !== 'gpt-skin' && currentSlot !== 'gpt-superstitial' && currentSlot !== 'gpt-overlay' ) {
			IDG.GPT.viewable[currentSlot] = true;
			IDG.GPT.log("The ad in " + currentSlot + " counts as a viewable impression.");
			
			IDG.GPT.refreshCountdown[currentSlot] = {};
			//if slot visibility > 50, start countdown timer
			if (IDG.GPT.visibility[currentSlot] >= 50) {
				IDG.GPT.refreshCountdown[currentSlot].timeRemaining = refreshInterval;
				IDG.GPT.refreshCountdown[currentSlot].interval = setInterval(function(){
					refreshCountdown(currentSlot);
				}, 1000)			
				IDG.GPT.log('Impression viewable - starting countdown for ' + currentSlot);
			}
		}
	});
};



IDG.GPT.visibilityChanged = function() {
	googletag.pubads().addEventListener('slotVisibilityChanged', function (event) {
		var currentSlot = event.slot.getSlotElementId();
		var currentVisibility = event.inViewPercentage;
		
		if (currentSlot !== 'inread' && currentSlot !== 'gpt-skin' && currentSlot !== 'gpt-superstitial' && currentSlot !== 'gpt-overlay' ) {
			if (typeof IDG.GPT.visibility[currentSlot] !== "undefined") {
				//if this slot has a viewable impression...
				if (typeof IDG.GPT.viewable[currentSlot] === "boolean" && IDG.GPT.viewable[currentSlot] == true) {
					//if stored value < 50 and current value >=50, start countdown timer
					if (IDG.GPT.visibility[currentSlot] < 50 && currentVisibility >= 50) {
						IDG.GPT.refreshCountdown[currentSlot].timeRemaining = refreshInterval;
						IDG.GPT.refreshCountdown[currentSlot].interval = setInterval(function(){
							refreshCountdown(currentSlot);
						}, 1000)
						IDG.GPT.log('Came into view - restarting countdown for ' + currentSlot);
					}
					//else if stored value >= 50 and current value < 50, stop countdown timer (if exists)
					else if (IDG.GPT.visibility[currentSlot] >= 50 && currentVisibility < 50) {
						clearInterval(IDG.GPT.refreshCountdown[currentSlot].interval);
						IDG.GPT.log('Went out of view - stopping countdown for ' + currentSlot);
					}
				}
				//update visibility
				IDG.GPT.visibility[currentSlot] = currentVisibility;
			}
			else {
				//set initial visibility
				IDG.GPT.visibility[currentSlot] = currentVisibility;
			}
			
			IDG.GPT.log(currentSlot + " visibility: " + currentVisibility);
		}
	});
};

IDG.GPT.googleCommandPush(IDG.GPT.impressionViewable);
IDG.GPT.googleCommandPush(IDG.GPT.visibilityChanged);



</script>


<script type="text/javascript">
	if (adLayer==null || adLayer=='undefined') {
		var adLayer=[];
	}
	
		
			adLayer["itemType"]="article";
		
		
	
</script>
	
<script type="text/javascript">
	// Set up ad related variables
	try {
		IDG.GPT.unitName = "/8456/IDG.G_B2B_Computerworld.com";
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}

	try {
		IDG.GPT.unitName = IDG.GPT.unitName + "/" + "android_section";
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}
	// global variables
	var global_ShowSuper = true;
	var global_ShowHero = false;
	
	//XFP global targeting, more targeting thm_pre
	var url = window.location.href;
	if(url.indexOf("?")>1){
		url=url.split('?')[0];
	}
	

	try {
		IDG.GPT.addTarget("URL", encodeURIComponent(url));
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}
	try {IDG.GPT.addTarget("zone", 'article-blog/android');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try{IDG.GPT.addTarget("channel", 'mobile,internet');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("blogId", '1035');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("articleId", '3566143');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("type", 'newsanalysis');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("typeId", '7');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("manufacturer", 'microsoft');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("templateType", 'article-default');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	
	try {IDG.GPT.addTarget("categoryIds", ['3145','3028','3404','4157','4119','3387','3779']);}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try{IDG.GPT.addTarget("categorySlugs", ['android','mobile','microsoft','microsoft-surface','google','mobile-apps','web-applications']);}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try {IDG.GPT.addTarget("goldenIds", ['233','931','804','819','778','1047','1059']);}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try {
		if (null != IDG.GPT.getQsVal("env")) {		
			IDG.GPT.addTarget("env", IDG.GPT.getQsVal("env").replace(/\W/g, "") );
		}
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}	
	
		try {
			IDG.GPT.addTarget("author", 'JR Raphael');
		}
		catch (exception) {
			console.log ("google_dfp can't use IDG.GPT "+ exception);
		}
	
	
	
		

	try {
		IDG.GPT.addTarget("page_type", '');
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}	

	
		try {
			IDG.GPT.addTarget("blog_name", 'Android Intelligence');
		}
		catch (exception) {
			console.log ("google_dfp can't use IDG.GPT "+ exception);
		}
	
	
	
	
		try {
			IDG.GPT.addTarget("insiderContent", 'false');
		}
		catch (exception) {
			console.log ("google_dfp can't use IDG.GPT "+ exception);
		}
	
	
	
	
	
	
	//k/v for Inskin partner
	var fn_pageskin = screen.width >= 1330 ? "true" : "false";
	try {
		IDG.GPT.addTarget("inskin_yes", fn_pageskin);
        IDG.GPT.log("Inskin: added k/v pair inskin_yes : "+fn_pageskin);
	} catch (exception) {
		console.log("Inskin: google_dfp can't use IDG.GPT " + exception);
	}
</script>



<script type="text/javascript">
	
	
	
	
		
		
		
		
		
		
		
		
	
	
	
			try {
					IDG.GPT.isNewHeader = true;
				}
				catch (exception) {
					console.log ("google_dfp can't use IDG.GPT "+ exception);
				}
	
	
	

</script>
  
<script src="/www.idge/js/thm_pre.js?v=20200708115223"></script>


	
	
		<script>
		// IDGMPM-16419 - moved out of adsel queue for IDGMPM-16933
		googletag.cmd.push(function() {
		  if (googletag.pubads().getTargeting('permutive').length == 0) {
			
			//IDGMPM-18418 - capture paermutive key-values
			window.headertag = window.headertag || {};
			window.headertag.cmd = window.headertag.cmd || [];
			window.headertag.cmd.push(function() {
				try {
					var segs = JSON.parse(localStorage._pdfps || '[]').slice(0,250);
					window.headertag.setUserKeyValueData({ segments: {"permutive": segs} });                
				} catch (e) {}
			});
			
		    var kvs = localStorage.getItem('_pdfps');
		    googletag.pubads().setTargeting('permutive', kvs ? JSON.parse(kvs) : []);
		    console.log('ad targeting permutive kvs: ', kvs);
		  }
		});
		</script>
	

<script type="text/javascript" src="/www/js/ads/gpt_starter.js?1234"></script>
	<script>
		loadGPT();
	</script>

	
		<script type="text/javascript" src="/www/js/ads/ias_gpt_launcher.js?v=20200708115223"></script>
	

	



		
		
	
	
	
		
				
		
		
		
	

	<link rel="canonical" href="https://www.computerworld.com/article/3566143/microsoft-android-transformation.html" />
	
	
		
	

	<meta itemprop="url" content="https://www.computerworld.com/article/3566143/microsoft-android-transformation.html" />
	<meta name="description" content="Blink and you might miss it, but Microsoft is little by little reshaping Google&#039;s mobile ecosystem for the better — and all signs suggest it&#039;s only getting started." />
	
		
			<meta name="DC.date.issued" content="2020-07-14T09:15-05:00" />
			<meta name="date" content="2020-07-14" />
			
		
		
		
		
	
	
	<link rel="amphtml" href="https://www.computerworld.com/article/3566143/microsoft-android-transformation.amp.html" />
	
		
		
		
			
			
				
			
			
			
		
	
	
		
		
			<meta property="og:title" content="The Microsoft-Android transformation is about to affect us all">
		
	
	<meta property="og:description" content="Blink and you might miss it, but Microsoft is little by little reshaping Google&#039;s mobile ecosystem for the better — and all signs suggest it&#039;s only getting started.">	
	
	
		
			<meta property="og:image" content="https://images.idgesg.net/images/article/2020/07/microsoft-android-100851580-large.jpg" />
			<meta property="og:image:width" content="1200" />
			<meta property="og:image:height" content="800" />
			<meta itemprop="image" content="https://images.idgesg.net/images/article/2020/07/microsoft-android-100851580-large.jpg" />
			<meta itemprop="thumbnailURl" content="https://images.idgesg.net/images/article/2020/07/microsoft-android-100851580-large.jpg" />
			<link rel="image_src" href="https://images.idgesg.net/images/article/2020/07/microsoft-android-100851580-large.jpg" />
			<meta name="twitter:image" content="https://images.idgesg.net/images/article/2020/07/microsoft-android-100851580-large.jpg" />
		
		
	
	
		
			<meta property="og:type" content="article" />
			
			
			
			
			
			
			
			
			
			<meta name="author" content="JR Raphael">
			
			
			
			
			
		
		 
		
	<meta property="og:site_name" content="Computerworld" />
	<meta property="fb:app_id" content="123026274413041" />
	
		
			<meta property="og:url" content="https://www.computerworld.com/article/3566143/microsoft-android-transformation.html">
		
		
	
	
	<!-- Use Twitter Summary Card with Large Image for articles and videos -->
	
		
				<meta name="twitter:card" content="summary_large_image">
		
		
	

	<meta name="twitter:site" content="@computerworld">
	<meta name="twitter:description" content="Blink and you might miss it, but Microsoft is little by little reshaping Google&#039;s mobile ecosystem for the better — and all signs suggest it&#039;s only getting started.">

	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
		<meta property="fb:pages" content="103687894679" />
	
	
	<meta name="rating" content="General">
	
	<meta name="robots" content="NOODP,NOYDIR" />
	
	
		<meta name="google-site-verification" content="_JEYLpDBDU_w1eI6P77BYlB1lvpukoxFcYDS_-Aznko" />
	
	
	
		<meta name="msvalidate.01" content="04917178B598F0648B9BAD693FEC29A3" />
	
		
	<!-- pagination -->
	
	
	
	
	
	
	
	
	
	
	
					
		
		
			
			
		
	
	
	<!-- css -->
	
	
	
		
			
			
			
			
				
					
						
						
							<link rel="stylesheet" href="/www/css/article.css?v=20200708115223" />
						
					
					
					
					
			
				
		
		
		
			<link rel="stylesheet" href="/www.idge/css/insider-promo-styles.css?v=20200708115223" />
		
		<link rel="stylesheet" href="/www.idge/css/print.css" media="print" />
		
	
	
		
			
			
				
				
					<link rel="stylesheet" href="/www.idge.ctw/css/article.css?v=20200708115223" />
				
			
		
	
	
	<link rel="stylesheet" href="/www.idge/css/webfonts/ss-social.css" />
	<link rel="stylesheet" href="/www.idge/css/webfonts/ss-standard.css" />
	<!--[if lte IE 8]>  
		<link href="/www.idge/css/webfonts/ss-ie8.css" rel="stylesheet" />
	<![endif]--> 
	
	

	
		
	
	
	
		<link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.6.1/css/all.css" integrity="sha384-gfdkjb5BdAXd+lj+gudLWI+BXq4IuLW5IT+brZEZsLFm++aCMlF1V92rMkPaX4PP" crossorigin="anonymous">
	
	
	
		<link rel="stylesheet" href="https://use.typekit.net/cav2eef.css" />
	
	
	<!--  fav and touch icons -->
	<link rel="shortcut icon" type="image/x-icon" href="https://idge.staticworld.net/ctw/favicon.ico"/>
	<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://idge.staticworld.net/ctw/computerworld-logo144x144.png" />
	<link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://idge.staticworld.net/ctw/computerworld-logo114x114.png" />
	<link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://idge.staticworld.net/ctw/computerworld-logo72x72.png" />
	<link rel="apple-touch-icon-precomposed" sizes="57x57" href="https://idge.staticworld.net/ctw/computerworld-logo57x57.png" />
	<link rel="apple-touch-icon" href="https://idge.staticworld.net/ctw/computerworld-logo300x300.png" />
	
	
	
	
	
		<script>
			$(document).ready(function(){
				if(typeof(IDG.insiderReg.readCookie('nsdr')) !== 'undefined'){
					$('#welcome-message').show();			
					IDG.insiderReg.personalize();
				}else{
					$('.signin-register').show();	
				}
			});
		</script>
   	    
   	    











<script>
var isProd = 'true';

var ocEnabledSite = "true";

var brandCode = "ctw";
var brandName="Computerworld";
var brandId = "6";
var regDebugLog=false;

// Marketing Channels Preference
var brandIdDemandgen=false;
var brandIdEvents=false;
var brandIdResearch=false;
var brandIdThirdparty=false;
var isEu=false;

// API URL and API key
var regApiUrl='https://api-stage.idgcommunications.net/api/v1/'; // replaced below with property in .properties file
var apiKey="HLyMXLISSW7HAYGgbx2Vb1Gf1OLcGmMG5BcwZ4Vb";

var tokenPrefix='www';
var tokenSuffix='.com/insider/token?';
var brandDomain=".computerworld.com";
var insiderContentType="article";
var notEmptyArticle=false;
var notEmptyMediaResource=false;
var isInsiderPremium=false;
var isResourceInsiderPremium=false;

var ownerIds=["0c99a1d7-c4e7-42a5-910f-a22134d1f98d"];
var campaignId="2a3b7224-f920-41a1-bea6-615aa59ea0f8";
var assetId="697422d1-7acb-40f6-be13-0e67329bc9ec";
var placementId="2d44d74a-e883-4d18-ada8-b2f0e61a1d90";
var clientCompany="IDG Communications US";
var businessUnit="IDG Communications US";

</script>
<script>
function getOneRegIDs(countryCode) {
	let obj = {};
	if (countryCode === 'uk') {
		obj={
			brandId: "91",
			ownerIds: ["f3efa90a-2330-4d42-bbc7-f7f96eb0f3db"],
			campaignId: "a465ea50-b639-4f98-ad1c-bc0b8c80e3c9",
			assetId: "5ab2586f-3bb6-4ad3-84e2-bdd230980e88",
			placementId: "77a1e657-f12c-4f7c-b685-6a9da2eb25d6",
			businessUnit: "IDG UK"
		}
	}
	if (countryCode === 'africa') {
		obj={
			brandId: "",
			ownerIds: ["02b2821f-2118-442a-9f16-df416847133f"],
			campaignId: "89c3e1d5-f5c6-4934-b683-751414ffe5b7",
			assetId: "8848c7a9-7ed0-4119-ba20-e9f06869928c",
			placementId: "7d80c555-1916-4c7b-bd56-dd10767d83b8",
			businessUnit: "IDG Connect"
		}
	}
	if (countryCode === "asean") {
		obj={
			brandId: "",
			ownerIds: ["02b2821f-2118-442a-9f16-df416847133f"],
			campaignId: "77f2f4c1-c3f3-4796-be52-d44c982bc824",
			assetId: "59fdb971-7da7-48a0-bd6d-e52db502b83f",
			placementId: "b1f22813-ff0d-42d8-90d9-c1fbd47b3424",
			businessUnit: "IDG Connect"
		}
	}
	if (countryCode === 'mideast' || countryCode === 'middle-east') {
		obj={
			brandId: "",
			ownerIds: ["02b2821f-2118-442a-9f16-df416847133f"],
			campaignId: "2e8ce243-c3b2-417b-a893-ba4fb496776b",
			assetId: "511c10e5-69b7-4a0d-861f-99b048e129f8",
			placementId: "59a18947-cead-4faf-8d94-2fd9bba346a4",
			businessUnit: "IDG Connect"
		}
	}
	if (countryCode === 'in') {
		obj={
			brandId: "56",
			ownerIds: ["b6973a30-3c15-4667-9165-e206b8876adc"],
			campaignId: "cf43ee09-cb17-4704-aec9-3c3faefee27f",
			assetId: "f411310d-fa2f-4518-93c9-e08962d736b2",
			placementId: "6813ef80-eb35-4d48-94f0-4b64c406ca52",
			businessUnit: "IDG India"
		}
	}
	if (countryCode === 'au') {
		obj={
			brandId: "62",
			ownerIds: ["dfcefb71-7919-4a1b-9b77-6a1c05314109"],
			campaignId: "371454ac-79e0-4bef-9a02-6ba52dc58e51",
			assetId: "fe648fe7-937f-4f7d-8822-2125efbbde26",
			placementId: "d6d61fb9-333b-4721-ae7a-3b069224c628",
			businessUnit: "IDG Australia"
		}
	}
	if (countryCode === 'nz') {
		obj={
			brandId: "64",
			ownerIds: ["dfcefb71-7919-4a1b-9b77-6a1c05314109"],
			campaignId: "371454ac-79e0-4bef-9a02-6ba52dc58e51",
			assetId: "fe648fe7-937f-4f7d-8822-2125efbbde26",
			placementId: "d6d61fb9-333b-4721-ae7a-3b069224c628",
			businessUnit: "IDG New Zealand"
		}
	}

	return obj;
}
</script>

<script>
if (countryCode !== "" && countryCode !== "us") {
	clientCompany="IDG Communications";
	
	let oneRegIDs = getOneRegIDs(countryCode);
	
	brandId = oneRegIDs.brandId;
	ownerIds = oneRegIDs.ownerIds;
	campaignId = oneRegIDs.campaignId;
	assetId = oneRegIDs.assetId;
	placementId = oneRegIDs.placementId;
	businessUnit = oneRegIDs.businessUnit;
}
if (countryCode == 'nl') {
	brandId = "103";
	ownerIds=["995bcc26-0146-4b23-a843-e4a9dab15ab2"];
	campaignId="9c573c52-3bb0-406c-8925-8ae3610d4b46";
	assetId="d8343ec7-7fd4-4232-b227-62d98ea9525b";
	placementId="3dbe27d8-52a6-4b42-b07a-cdd7dc6f5b97";
	clientCompany="IDG Communications";
	businessUnit="IDG Benelux";
}
if (countryCode == 'nl') {
	brandId = "103";
	ownerIds=["995bcc26-0146-4b23-a843-e4a9dab15ab2"];
	campaignId="9c573c52-3bb0-406c-8925-8ae3610d4b46";
	assetId="d8343ec7-7fd4-4232-b227-62d98ea9525b";
	placementId="3dbe27d8-52a6-4b42-b07a-cdd7dc6f5b97";
	clientCompany="IDG Communications";
	businessUnit="IDG Netherlands";
}


	regApiUrl="https://lqxgcyk808.execute-api.us-east-1.amazonaws.com/prod_h2/api/v1/";



	regDebugLog=false;



	tokenPrefix="http://www";



	tokenSuffix="/insider/token";





	notEmptyArticle=true;


	



 

</script>














	



	
	
	
















	

	
	<script src="/www/js/ads/ad.js"></script>
	
	<script>var oneRegPlacementID = "";</script>
	
	<script>
		const articlePaidAccess = [];
	</script>
	
	
	
		
			
				
			
			
			
			
			
			
			
			

				
			
		
		
		
	
	
		
	
	
	
	
	
	





	
		
	
		
	
	





		
		  
		
		
		
		

	
	
	
	
	

	
	  	 
	    
	    
	 
	 
	
	
	
	
	
	
	
	
	
	
		
		
		
	

	<script>
	var supMontMods = false;
	</script>
	
	
	
	
		
		
		
		
			
				
				
			











	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
		<!-- blx4 #2806 blox4.simple  -->
			

		
			
				
					
					
					
						
							
					
						
					
					
					
					
					
					
						
					
				
				
			
		















	
		
		
	
		
		
	
		
		
	
		
		
	
		
		
	
		
		
	
		
		
	
		
		
	
		
		
	
		
		
	
		
		
	
		
		
	
		
		
	
		
		
	
		
		
	
		
		
	
		
		
	
		
		
	
		
		
	
		
		
	
		
		
	
		
		
	
		
		
	
		
		
	
		
		
	
		
		
	
		
		
	
		
		
	
		
		
	
		
		
	
		
		
	
		
		
	
		
		
	
		
		
	


	


		
	
	
	
	
	
	
	
	
	
	
	
		
			
				
				
				
					
				
			
			
			
			
		
		
		
	
	
	
	
	
	
	
	

	
	
	
	
	
		 
		

		<script>	
		{	
			let categorySlug = 'android';
			
			const stripOutIllegal = s => s.replace(/[~'"=!+#;^()<>&[]]/g,'');
			
			window.ntvConfig = window.ntvConfig || {} ;
			window.ntvConfig.keyValues = window.ntvConfig.keyValues || {};
			const segs = localStorage.getItem('_pnativo');
			if (segs) {
				window.ntvConfig.keyValues.permutive = JSON.parse(segs).join(",");
			}
			
			const metaKeywordsTag = document.querySelector("meta[name='keywords']");
			if ( metaKeywordsTag && (metaKeywordsTag.hasAttribute('content')) ) {
				const kwds = metaKeywordsTag.content.split(',').filter(kw => kw.length <= 40);
				window.ntvConfig.keyValues.contextual = stripOutIllegal(kwds.join(','));
			}
			[categorySlug].forEach(function(val) {
				if (val.length !== 0) {
					window.ntvConfig.keyValues.channel = stripOutIllegal(val);
				}
			});
			if (typeof(window.ntvConfig.keyValues.channel) === "undefined") {
				window.ntvConfig.keyValues.channel = "";
			}
		}
		</script>
	
	
	
	
		<script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
	

	
	
	
	<script type="text/javascript">
		var prodNames = '';
		var prodManufacturers = '';
		var prodCategories = '';
		var prodVendors = '';
	</script>
	
	
	
		
		<script src="/www/js/insider/insider_reg_api.js?v=20200708115223"></script>
	
	
	
	<script>
	var insiderSignedIn = document.cookie.indexOf("nsdr") > -1; //check if Insider cookie exists
	var idg_uuid = $.cookie('idg_uuid') || '';
	
	var dlJobFunction = '';
	var dlJobPosition = '';
	var dlIndustry = '';
	
	if (insiderSignedIn) {
		var insiderToken = IDG.insiderReg.readCookie("nsdr");
		var tokens = IDG.insiderReg.readCookieProperty(insiderToken);
		if (!(tokens['jobPosition']===undefined)) {
			//dlJobPosition = tokens['jobPosition'];
			//OC-1647 change to indicate this data was remove
			dlJobPosition = "removed";
		}
		if (!(tokens['jobFunction']===undefined)) {
			dlJobFunction = tokens['jobFunction'];
		}
		if (!(tokens['industry']===undefined)) {
			dlIndustry = tokens['industry'];
		}
	}
	
	insiderSignedIn = insiderSignedIn.toString(); //per Infotrust this needs to be a string, not a boolean
	
	var sincePublished = '0 days';
	sincePublished = sincePublished.split(" ")[0];
	
	//get edition from countryCode
	var edition = '';
	if (typeof countryCode !== 'undefined' && countryCode !== "") {//should be defined in locales-editions.jsp if brand has editions
		edition = countryCode.toLowerCase();
	}

	var catIdList = '3145,3028,3404,4157,4119,3387,3779';
	var goldenTaxList = '233,931,804,819,778,1047,1059';
	var primaryCatList = 'android,mobile,microsoft,microsoft surface,google,mobile apps,web applications';
	
	dataLayer.push({
		'articleId': '3566143',
		'articleDisplayId':'1',
		'articleHasVideo':'false',
		'articleLocale': 'global',
		'articleTitle': 'The Microsoft-Android transformation is about to affect us all',
		'articleType': 'News Analysis',
		'audience':'enterprise',
		'author':'JR Raphael',
		'blogName':'Android Intelligence',
		'brandpost': 'false',
		'categoryIdAll': (catIdList.length > 0 ? catIdList.split(',') : []),
		'categoryIdList':catIdList,
		'categoryIdPrimary': '3145',
		'contentStrategy': '',
		'contentType':'newsanalysis',
		'datePublished':'2020-07-14',
		'dateUpdated':'2020-07-14',
		'daysSincePublished':"0",
		'daysSinceUpdated':'0',
		'de_normalized_company_name':$.cookie('de_normalized_company_name'),
		'displayType':'article',
		'edition':edition,
		'environment':'production',
		'ga_enabled':'true',
		'gaTrackingId':'UA-300704-1',
		'geolocEnabled':'true',
		'goldenTaxArray': (goldenTaxList.length > 0 ? goldenTaxList.split(',') : []),
		'goldenTaxonomyIdAll': '233, 931, 804, 819, 778, 1047, 1059',
		'goldenTaxonomyIdPrimary': '233',
		'goldenTaxonomyIdList': '931,804,819,778,1047,1059',
		'industry': dlIndustry,
		'insiderSignedIn':insiderSignedIn,
		'ip_normalized_company_name':$.cookie('ip_normalized_company_name'),
		'isBlog':'true',
		'isInsiderContent':'false',
		'isICN': 'false',
		'jobFunction': dlJobFunction,
		'jobPosition': dlJobPosition,
		'oneRegPlacementID':oneRegPlacementID,
		'pageNumber':'1',
		'platform':'Web',
		'podcastSponsored': 'false',
		'primaryCategory': 'android',
		'ancestorGoldenCategories': 'operating systems',
		'primaryCatArray': (primaryCatList.length > 0 ? primaryCatList.split(',') : []),
		'primaryCategoryAll': 'android, mobile, microsoft, microsoft surface, google, mobile apps, web applications',
		'primaryCategoryList': 'mobile,microsoft,microsoft surface,google,mobile apps,web applications',
		'primaryAncestorCategoryList': 'hardware,software,technology industry,operating systems,android',
		'prodCategories':prodCategories.slice('|', -1),
		'prodManufacturers':prodManufacturers.slice('|', -1),
		'prodNames':prodNames.slice('|', -1),
		'prodVendors':prodVendors.slice('|', -1),
		'property': 'computerworld',
		'propertyCountry':'US',
		'purchaseIntent':'notapplicable',
		'skimlinksId':'111346X1569473',
		'source':'computerworld',
		'sponsorName':'',
		'suppressMonetization': supMontMods.toString(),
		'tags': '',
		'userId':idg_uuid,
		'videoAutoplay':'false',
		'youtubeId':''
	});
	</script>

	
	
	










<script>
	var dataLayer = window.dataLayer = window.dataLayer || [];
	var adBlockStatus = 'false';
	
	//look for variable set in ad.js
	if (window.canRunAds === undefined) {
		adBlockStatus = 'true';
	} else {
		adBlockStatus = 'false';
	}
	
	dataLayer.push({
		'adBlockStatus': adBlockStatus
	});
</script>





	<!-- Google Tag Manager -->
	<noscript><iframe src="//www.googletagmanager.com/ns.html?GTM-WR6LD2P"
	height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
	<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-WR6LD2P');</script>
	<!-- End Google Tag Manager -->

	
	
	
		<script>
			var numberFromDataLayer = function(property) {
			  if (window.dataLayer && dataLayer[0] && typeof dataLayer[0][property] == "number") {
			    return dataLayer[0][property];
			  }
			  return null;
			};
			
			var stringFromDataLayer = function(property) {
			  if (window.dataLayer && dataLayer[0] && typeof dataLayer[0][property] == "string") {
			    return dataLayer[0][property];
			  }
			  return "";
			};
		</script>
	

	

	
		










<script>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</script>

<script>
	$.ajax({
		url: "https://cdn.permutive.com/f5b3be27-f789-4ef1-8867-37c67da5b361-web.js",
	  	dataType: "script",
	  	cache: true, // default is false
	  	async: true // default is true
	});
</script>
	
	
	
	
	

	

	
	
		











<style>
@media only screen and (max-width: 929px) {
	.brVideoContainer {
    	width: 100%;
  		height: auto;
  		display: inline-block;
        position: relative;
  		border: none;
  		overflow: hidden;
  		z-index: 10000;
	}
  	#bottomRightPlayer {
      	margin-bottom: 10px;
    }
    .margin-col .brVideoContainer,
  	.main-col .brVideoContainer {
      	margin-top: 20px;
  	}
}
@media only screen and (min-width: 930px) {
	.brVideoContainer {
  		bottom: 5px;
  		right: 5px;
  		width: 401px;
  		height: 225px;
      	position: fixed;
        border: none;
      	overflow: hidden;
  		z-index: 1400000;
	}
}

.brVideoContainer .outer-wrapper {
	margin: 0 auto;
    max-width: 600px;
  	top: 0px;
  	left: 0px;
  	width: 100%;
  	height: 100%;
  	border: none;
  	overflow: hidden;
  	position: relative;
}

#jw-standalone-close-button {
  position: absolute;
  top: 5%;
  right: 3%;
  display: inline;
  z-index: 999999;
  height: 20px;
  width: 20px;
}
</style>



<script src="https://cdn.jwplayer.com/libraries/8yHZorDV.js"></script>

<script>
	let brandAbbreviation = "";
</script>

	<script>
		brandAbbreviation = "ctw";
	</script>


<script>
if (edition === "us" || (edition === "uk" && brandAbbreviation === "ctw")) {
	googletag.cmd.push(function() {
		consent.ads.queue.push(function(){ 
		  var customParams = {
		    "dlm": googletag.pubads().getTargeting('dlm'),
		    "fr": googletag.pubads().getTargeting('fr'),
		    "grm": googletag.pubads().getTargeting('grm'),
		    "vw":googletag.pubads().getTargeting('vw'),
		    "URL": IDG.GPT.targets["URL"],
		    "articleId": IDG.GPT.targets["articleId"],
		    "blogId": IDG.GPT.targets["blogId"],
		    "categoryIds": IDG.GPT.targets["categoryIds"],
		    "categorySlugs": IDG.GPT.targets["categorySlugs"],
		    "channel": IDG.GPT.targets["channel"],
		    "env": IDG.GPT.targets["env"],
		    "goldenIds": IDG.GPT.targets["goldenIds"],
		    "pagetype": adLayer["itemType"],
		    "permutive": localStorage.getItem('_pdfps'),
		    "playertype": "bottomRightPlayer",
		    "pos": "bottom_right",
		    "positiondata": buildPositionData("bottom_right"),
		    "sponsored": IDG.GPT.targets["sponsored"],
		    "tagNames": IDG.GPT.targets["tagNames"],
		    "zone": IDG.GPT.targets["zone"],
		    "devsite": IDG.GPT.targets["devsite"]
		  };
		  
		  var custAdTag = "https://pubads.g.doubleclick.net/gampad/ads?sz=640x480&iu="+IDG.GPT.unitName+"&ciu_szs=300x250,728x90&impl=s&gdfp_req=1&env=vp&output=vast&unviewed_position_start=1&description_url=http%3A%2F%2Fwww.computerworld.com&url=[referrer_url]&correlator=[timestamp]";
		  
		  var customAdRoll = [
		  		   {
		              "tag": custAdTag,
		              "offset":"pre",
		              "custParams": customParams
		           },	
		  		];

		  if (edition === 'us') {
		  	 if (true==true) {
			    
			  	  
			    
			    	for (let i = 0; i < [30,60,90].length; i++) { 
					  customAdRoll.push({
				         "tag": custAdTag,
				         "offset": [30,60,90][i],
				         "custParams": customParams
				      });
				    }
				    
				   
				   
				
			  }
		  }
		  
		  var videoPlayerMarkup='<div class="brVideoContainer" itemscope itemtype="http://schema.org/VideoObject"><div class="outer-wrapper"><img onclick="jwplayer(\'bottomRightPlayer\').remove(); this.style.display = \'none\';" id="jw-standalone-close-button" src="data:image/png;base64,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" /><div id="bottomRightPlayer"></div></div></div>';
		  $('body').prepend(videoPlayerMarkup);
		
		    
		   jwplayer("bottomRightPlayer").setup({ 
		      "playlist": "https://cdn.jwplayer.com/v2/playlists/xAPwXviG?search=__CONTEXTUAL__",
		      "autostart": true,
		      "mute": true,
		      "advertising": {
		        "client": "googima",
		        "loadVideoTimeout": 60000,
		        "creativeTimeout": 60000,
		        "requestTimeout": 60000,
		        "adscheduleid": "LxK3nuOJ",
		        "schedule": customAdRoll
		      }
		   });
		   
		   $(function() {
			    // article
			   	if ($("#drr-container").length > 0) {
			  		$("article .bodee #drr-container p:nth-of-type(4)").after($(".brVideoContainer"));
			   	}
			    // index pages - enterprise
			    if ($(".main-col").length > 0) {
			        $(".main-col > div:nth-of-type(6)").after($(".brVideoContainer"));
			    }
			    // index pages - consumer
			    if ($(".landing-listing").length > 0) {
			        $(".landing-listing > div:nth-of-type(6)").after($(".brVideoContainer"));
			    }
			    // search results
			    if ($("body#search .search-results").length > 0) {
			        $(".search-results > div.river-well:nth-of-type(6)").after($(".brVideoContainer"));
			    }
			    // custom search results
			    if ($(".gsc-result").length > 0) {
			        $(".gsc-expansionArea > div.gsc-result:nth-of-type(6)").after($(".brVideoContainer"));
			    }
			  });
		   
		   $("#jw-standalone-close-button").click(function() {
				$(".brVideoContainer").remove();
			});
		   
		});
	});
}	
</script>
	
	
</head>



	<body id="article3566143" class="article blog1035 computerworld">
		
			
			
					
					
						
						
					





















	

		
			
			
				<!-- Begin welcome ad overlay - gpt-overlay position  -->
				
				
					<div id="superadunit" class="hidden">
						<div class="ad">
							<div class="ad-header">
								<div class="brand-logo"></div>
								<a href="javascript:unhide('superadunit');" id="superstitial-text">Close Ad</a>
							</div>
							<div id="gpt-overlay" class=" ad-container">
								<script type="text/javascript">
								consent.ads.queue.push(function(){
									IDG.GPT.addDisplayedAd("gpt-overlay", "true");
									IDG.GPT.displayGoogleTagSlot('gpt-overlay');
								});
								</script>
							</div>
						</div>
					</div>
				
				<!--  End welcome ad overlay - gpt-overlay position -->
				
			
			
			
			
			
			
		
	
 	
 
 
				
			
		
		











	
		<link rel="stylesheet" href="/www/css/oc-header.css?v=20200708115223" />
		<link rel="stylesheet" href="/www.idge.ctw/css/oc-header.css?v=20200708115223" />
		











<header id="banner">
	
		<div class="ad">
			
				
			





















	

		
			
			
			
			
			
			
				<div id="oc_ad_1" class=" ad-container test">					
				</div>				
				<script type="text/javascript">
				consent.ads.queue.push(function(){
				
					IDG.GPT.addDisplayedAd("oc_ad_1", "true");
					$('#oc_ad_1').responsiveAd({screenSize:'971 1115', scriptTags: []});
                    IDG.GPT.log("Creating ad: oc_ad_1 - [971 1115]");
                    
				
				});
				</script>
			
		
	
 	
 
  
		</div>
	
	
	
</header>
<script>
$(document).ready(function() {
	var params = {
			def : "blox4.dynamic",
			geo : getLocale(),
			definition : "nav.fixed",
			placement : "Nav Fixed"
			}
		$.get(
			"/napi/tile",
			params,
			function(data, status, xhr) {
				$('#custom_header').html(data);
			},
			"html");
});
	
//This is for sites without editions but using the new header and mega menu.
var hasEditions = "";
if ("true" !== "" && "true" !== null) {
	hasEditions = true;
}
</script>
<section id="oc-head" class="no-stick-important">
		<div class="oc-head-inner">
			<div class="oc-head-left">
				<a href="/" class="masthead"><span class="logo">computerworld</span></a>
				
				
					
					
					
					
					<div class="edition-picker">
						<div class="current-edition" data-edition-name="current"><span id="current-edition">UNITED STATES</span> <i class="fas fa-caret-down"></i></div>
						<ul id="edition-picker-nav">

							
							   
							   
							   
							   
								   
									   <li class="edition-picker-item locale-">
									   		<a data-edition-name="US" data-edition-localeid="0" href="/">United States </a>
									   </li>
								   
								   
								
							
							   
							   
							   
							   
								   
								   
									   <li class="edition-picker-item locale-au">
									   		<a data-edition-name="au" data-edition-localeid="3" href="/au/">Australia </a>
									   </li>
								   
								
							
							   
							   
							   
							   
								   
								   
									   <li class="edition-picker-item locale-in">
									   		<a data-edition-name="in" data-edition-localeid="5" href="/in/">India </a>
									   </li>
								   
								
							
							   
							   
							   
							   
								   
								   
									   <li class="edition-picker-item locale-nl">
									   		<a data-edition-name="nl" data-edition-localeid="9" href="/nl/">Netherlands </a>
									   </li>
								   
								
							
							   
							   
							   
							   
								   
								   
									   <li class="edition-picker-item locale-nz">
									   		<a data-edition-name="nz" data-edition-localeid="4" href="/nz/">New Zealand </a>
									   </li>
								   
								
							
							   
							   
							   
							   
								   
								   
									   <li class="edition-picker-item locale-uk">
									   		<a data-edition-name="uk" data-edition-localeid="2" href="/uk/">United Kingdom </a>
									   </li>
								   
								
							

						</ul>
					</div>
				
				
			</div>
			
			<div id="custom_header">
			</div>
			
			<div class="oc-head-right">
				
					
				
				
					<div class="insider-controls">
						<div class="insider-controls-hover">
							<a class="insider edition-link-url" href="/insider/"></a>
							<i class="far fa-user"></i>
						</div>
					            	
					       <div id="insider-welcome">
						           <div id="insider-selector">				                        
						               <div class="stories">
						                        	
						                        	<div class="personalization"><strong>Welcome<span id="person-first-name"></span>!</strong> Here are the latest Insider stories.</div>
						                        	
						                        	











	
	
	
	
	
	
	
	
	
	
































































	<ul>
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
							
						
						
						
					











<li><a  href="/article/3541521/6-best-practices-for-business-data-visualization.html">6 best practices for business data visualization</a></li>
				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
							
						
						
						
					











<li><a  href="/article/3565752/how-to-filter-outlook-emails-on-all-your-devices.html">How to filter Outlook emails on all your devices</a></li>
				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
							
						
						
						
					











<li><a  href="/article/3220429/how-to-choose-the-right-windows-10-preview-and-update-channels.html">How to choose the right Windows 10 preview and update channels</a></li>
				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
							
						
						
						
					











<li><a  href="/article/3562719/how-to-work-across-time-zones-in-outlook.html">How to work across time zones in Outlook</a></li>
				
				
			
		
	</ul>




													
													<div class="sign-out-link">
														<a class="more-insider edition-link-url" href="/insider/">More Insider</a>
														<a class="sign-out" href="javascript://" onclick="IDG.insiderReg.logout()">Sign Out</a>
													</div>
										</div>										
		
						          </div>
						              <div class="signin-register">
						              		
											<a href="javascript://" onclick="IDG.insiderReg.registerLinkEvent('insider-reg-signin')" class="js-open-modal signin" data-modal-id="insider-popup">Sign In</a> 
											<a href="javascript://" onclick="IDG.insiderReg.registerLinkEvent('insider-reg-form-short')" class="js-open-modal register" data-modal-id="insider-popup">Register</a>	
										</div>
										<a class="nav-ip-dropdown" href="https://www.idginsiderpro.com/subscribe">
												<div><b><em>NEW</em></b> FROM IDG</div>
												<span class="dropdownIPLogo"></span>
												<span>Learn More</span>
										</a>
						   </div>
						         
					</div>
					  	
				
				
					<a href="#search" class="search-btn"><i class="fas fa-search"></i></a>
					<div class="search-expand">
						<a href="" class="mega-close ss-delete"></a>
						
					    
					   		  
						    		










<div class="gcse-searchbox" >
    <script>
		(function() {
			var cx = '011881588825642368632:cnkmmv0dvim';
			var gcse = document.createElement('script');
			gcse.type = 'text/javascript';
			gcse.async = true;
			gcse.src = 'https://cse.google.com/cse.js?cx=' + cx;
			var s = document.getElementsByTagName('script')[0];
			s.parentNode.insertBefore(gcse, s);
		})();
	</script>
	<gcse:searchbox-only resultsUrl="/search"></gcse:searchbox-only>
	<script>
		$(window).load(function(){
			const hdrSearchBox = document.querySelector(".gcse-searchbox input.gsc-input");
			hdrSearchBox.setAttribute("placeholder", "Start Searching");
		});
	</script>
</div>
							
							
						
						
					</div>
				
				
					<a class="mega-btn"></a>
					
				
			</div>
		</div>
</section>











<script>
$(document).ready(function() {	
	var paramsmegamenu1 = {
			def : "blox4.dynamic",
			geo : getLocale(),
			placement : "Nav Mega Column 1"
			}
		$.get(
			"/napi/tile",
			paramsmegamenu1,
			function(data, status, xhr) {
				$('#megacolumn1').html(data);
				if (hasEditions === true) {
					addSlugCode();
				}
			},
			"html");
	var paramsmegamenu2 = {
			def : "blox4.dynamic",
			geo : getLocale(),
			placement : "Nav Mega Column 2"
			}
		$.get(
			"/napi/tile",
			paramsmegamenu2,
			function(data, status, xhr) {
				$('#megacolumn2').html(data);
				if (hasEditions === true) {
					addSlugCode();
				}
			},
			"html");
	var paramsmegamenu3 = {
			def : "blox4.dynamic",
			geo : getLocale(),
			placement : "Nav Mega Column 3"
			}
		$.get(
			"/napi/tile",
			paramsmegamenu3,
			function(data, status, xhr) {
				$('#megacolumn3').html(data);
				if ( hasEditions === true) {
					addSlugCode();
				}
			},
			"html");
	var paramsmegamenu4 = {
			def : "blox4.dynamic",
			geo : getLocale(),
			placement : "Nav Mega Column 4"
			}
		$.get(
			"/napi/tile",
			paramsmegamenu4,
			function(data, status, xhr) {
				$('#megacolumn4').html(data);
				if (hasEditions === true) {
					addSlugCode();
				}
			},
			"html");
});
	
</script>
<nav class="megamenu">
		<div class="megamenu-inner">
			<div class="mega-mobile-nav">
				<a href="#search" class="search-btn"><i class="fas fa-search"></i></a>
				
				
					<div class="mega-insider-icons insider-controls">
					<i class="far fa-user"></i>
					<a class="insider" href="/about/learn-about-insider.html"></a>
					<a class="sign-out-link" href="javascript://" onclick="IDG.insiderReg.logout()">Sign Out</a>
					<div class="signin-register">
						<a href="javascript://" onclick="IDG.insiderReg.registerLinkEvent('insider-reg-signin')" class="js-open-modal signin" data-modal-id="insider-popup">Sign In</a> 
						<a href="javascript://" onclick="IDG.insiderReg.registerLinkEvent('insider-reg-form-short')" class="js-open-modal register" data-modal-id="insider-popup">Register</a>
					</div>
				</div>
				
			</div>
			<a href="" class="mega-close ss-delete"></a>
		
			<div class="mega-logo-content">
			<img class="mega-logo" src="https://alt.idgesg.net/images/furniture/computerworld/computerworld-np-logo.svg" />
			
			<div class="mega-4col">
				<div class="mega-col">
					
						<div class="mega-grp new-insiderpro">
							<div class="mega-hed">NEW <span>Insider</span> PRO
								<a class="ip-learnmore" href="https://www.idginsiderpro.com/subscribe">Learn More</a>
							</div>
						</div>
						<div class="mega-grp latest-insider">					
							<div class="mega-hed ss-directright right">Latest <span>Insider</span></div>
							
							











	
	
	
	
	
	
	
	
	
	
































































	<ul>
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
							
						
						
						
					











<li><a  href="/article/3563877/microsoft-wants-windows-10-servicing-calendars-here-are-two-more.html">Microsoft wants Windows 10 servicing calendars? Here are two more</a></li>
				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
							
						
						
						
					











<li><a  href="/article/3546420/download-discover-2020s-best-places-to-work-in-it.html">Download: Discover 2020&#039;s Best Places to Work in IT</a></li>
				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
							
						
						
						
					











<li><a  href="/article/3402059/download-the-best-places-to-work-in-it-archives-1994-to-2020.html">Download the Best Places to Work in IT archives, 1994 to 2020</a></li>
				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
							
						
						
						
					











<li><a  href="/article/3563728/windows-10-servicing-calendar-and-contradictions.html">Microsoft&#039;s Windows 10 servicing calendar: a showcase for contradictions</a></li>
				
				
			
		
	</ul>




							
							<div id="ip-below-personalize-list" class="mega-grp insider-controls">
								<a class="nav-ip-dropdown" href="https://www.idginsiderpro.com/subscribe">
									<div><b><em>NEW</em></b> FROM IDG</div>
									<span class="dropdownIPLogo"></span>
									<div>Learn More</div>
								</a>
							</div>
						</div>
					
					
						<div id="megacolumn1">
						</div>
				</div>
				<div class="mega-col">
						 <div id="megacolumn2">
						</div>
				</div>
				<div class="mega-col">
					
						
							<div class="mega-grp ip-controls">
								<span class="megamenuIPLogo"></span>
								<div class="mega-hed"><b>NEW FROM IDG</b></div>							
								<span>Subscribe to access expert insight on business technology - in an ad-free environment.. <a href="https://www.idginsiderpro.com/subscribe">Learn more</a> </span>
							</div>
							<div class="mega-grp insider-controls">
								<div class="mega-insider-icons">
									<a class="insider" href="/about/learn-about-insider.html"></a>
									<i class="far fa-user"></i>
								</div>
								<div class="personalization"><strong>Welcome<span id="person-first-name"></span>!</strong> Check out the latest Insider stories <a href="/insider" class="edition-link-url">here.</a></div>
								<a class="sign-out-link" href="javascript://" onclick="IDG.insiderReg.logout()">Sign Out</a>
								<div class="signin-register">
									
									<a href="javascript://" onclick="IDG.insiderReg.registerLinkEvent('insider-reg-signin')" class="js-open-modal signin" data-modal-id="insider-popup">Sign In</a> 
									<a href="javascript://" onclick="IDG.insiderReg.registerLinkEvent('insider-reg-form-short')" class="js-open-modal register" data-modal-id="insider-popup">Register</a>
								</div>
							</div>
						
						
					
					 <div id="megacolumn3">
					 </div>
				</div>
				<div class="mega-col">
					<div class="mega-grp idg-network">
						<div class="mega-hed ss-directright right">More from the IDG Network</div>
						
							<div id="megacolumn4">
						    </div>
					</div>
				</div>
			</div>
			</div>
			
			<div class="mega-footer">
				    	<ul class="mega-about">
				    		
		            		
							
							
							
								<li><a href="/about/about.html"  >About Us</a> <span class="bar">|</span>
							
								<li><a href="/about/contactus.html"  >Contact</a> <span class="bar">|</span>
							
								<li><a href="/about/privacy.html"  >Privacy Policy</a> <span class="bar">|</span>
							
								<li><a href="/about/cookie-policy.html"  >Cookie Policy</a> <span class="bar">|</span>
							
								<li><a href="/about/member-preferences.html"  >Member Preferences</a> <span class="bar">|</span>
							
								<li><a href="/about/contactus.html#advertise-with-us"  >Advertising</a> <span class="bar">|</span>
							
								<li><a href="https://www.idg.com/work-here/" target="_blank" rel="nofollow" >IDG Careers</a> <span class="bar">|</span>
							
								<li><a href="/about/adchoices.html"  >Ad Choices</a> <span class="bar">|</span>
							
								<li><a href="/about/affiliates.html"  >E-commerce Links</a> <span class="bar">|</span>
							
								<li><a href="/about/ccpa.html"  >California: Do Not Sell My Personal Info</a> <span class="bar">|</span>
							
						
		            	</ul>
		            	<ul class="mega-social">
		            		<li>Follow Us</li>
						
							<li class="lkndn"><a class="social-media-li" href="https://www.linkedin.com/company/computerworld" rel="nofollow" target="_blank"><i class="ss-icon ss-social-circle brand ss-linkedin"></i></a></li>
						
						
							<li><a class="social-media-tw" href="https://twitter.com/computerworld" rel="nofollow" target="_blank"><i class="ss-icon ss-social-circle ss-twitter"></i></a></li>
						
						
							<li><a class="social-media-fb" href="https://www.facebook.com/Computerworld" rel="nofollow" target="_blank"><i class="ss-icon ss-social-circle brand ss-facebook"></i></a></li>				
						
							
	            		</ul>
		            
			            <script>
			            	if (facebookUrl !== null && facebookUrl !== "") {
				            	document.querySelector(".social-media-fb").setAttribute("href", facebookUrl);
			            	}
			            	if (twitterUrl !== null && twitterUrl !== "") {
				            	document.querySelector(".social-media-tw").setAttribute("href", twitterUrl);
			            	}
			            	if (typeof linkedInUrl !== "undefined" && linkedInUrl !== null && linkedInUrl !== "") {
				            	document.querySelector(".social-media-li").setAttribute("href", linkedInUrl);
			            	}
			            </script>
					

		</div>
	</div>
	<div class="mega-submenu">
			<a href="" class="mega-mobile-nav ss-left"></a>
			<a href="" class="mega-close ss-delete"></a>
			<div class="submenu-contents"></div>
	</div>
</nav>



	<style>
		#insider-popup.modal-box {
			display: none;
			position: absolute;
			z-index: 6100000;
			width: 100%;
			background: transparent;
			border-bottom: 0 none;
			border-radius: 0px;
			box-shadow: none;
			border: 0 none;
			top: 0;
			bottom: 0;
			left: 0;
			right: 0;
			margin: 0 auto;
		}
		@media only screen and ( min-width: 48em ) {
			#insider-popup.modal-box {
				width: 770px;
			}
		}
		@media only screen and ( min-width: 60.625em ) {
			#insider-popup.modal-box {
				width: 850px;
			}
		}
	</style>



	<div id="insider-popup" class="modal-box ">
	
		<div class="insider-modal-wrapper">
	  
			<div class="modal-header-title">
				<div class="modal-banner-insider"><span class="insider"></span></div>
		    	<div class="modal-close close">×</div>
		  	</div>
		  	
		  	<div class="modal-body">
		  		
		  			
						<script>
$(document).ready(function(){
	$('a[data-link]').click(function() {
		
		  //get this link's dataLink value
		  var dataLink = $(this).attr('data-link');

		  //select the div with the same value
		  var toKeep = 'div[data-link="'+dataLink+'"]';
	
		  //select data-link divs that are not the above div
		  $('div[data-link]').not(toKeep).hide();
		  
		  if($(this).hasClass('link-transition')){
			  $(toKeep).fadeIn(800);
		  } else {
			  $(toKeep).show();
		  }
	
		  //prevent location change
		  return false;
	});
	

});
</script>

					
					
				
		  	</div>
		  	
		  	<div class="modal-footer">
		    	<div class="modal-close close-btn">Close</div>
		  	</div>
		</div>
	  	
	</div>

	<script>
		$(document).ready(function(){

			var appendthis =  ("<div class='modal-overlay modal-close'></div>");
			if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
				$('.modal-box').css({
					//top: ($(window).height() - $(".modal-box").outerHeight()) / 2,
					top: 10,
					left: 0
				});
			}
			
			
			if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
				$('.modal-box').height($(document).height());
				$('.modal-box').css('top','0');
			}
			
			var userAg = navigator.userAgent;

			$('a[data-modal-id]').click(function(e) {
				e.preventDefault();
				$('body').append(appendthis);
				$('.modal-overlay').fadeTo(500, 0.9);
				$('.modal-overlay').height($(document).height());
				var modalBox = $(this).attr('data-modal-id');
				
				if ($(".modal-box").hasClass('triggered') || (userAg.indexOf("Firefox")!=-1)) {
					$('#'+modalBox).fadeIn($(this).data()); // triggered by something other than onclick of link such as scroll to point in window
				} else {
					// IDGMPM-16177
					//if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
						$('#'+modalBox).toggle('slide', {direction: 'up'}, 800);
					//} else {
				   // 	$('#'+modalBox).toggle('slide', {direction: 'left'}, 600);
					//}
				}

				if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
					$("html, body").animate({
			            scrollTop: 0
			        }, 700);
			        
			        
			        $('a.btn.continue-on').click(function() {
			        	$('html, body').animate({
			        		scrollTop: 0
			        	}, 500);
			        });
			        
			        return false;
			        
				}
				if (navigator.userAgent.match(/(iPad)/)) {
					$("html, body").animate({
			            scrollTop: 0
			        }, 500);
				}
			});
		  
		  
			$(".modal-close, .modal-overlay").click(function() {
				$('.select2-drop').css('display','none');
				$(".modal-overlay").fadeOut(500, function() {
					$(".modal-overlay").remove();
				});
				if ($(".modal-box").hasClass('triggered') || (userAg.indexOf("Firefox")!=-1)) {
					$(".modal-box").fadeOut(500);
				} else {
					// IDGMPM-16177
					//if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
						$('.modal-box').toggle('slide', {direction: 'up'}, 800);
					//} else {
					//	$('.modal-box').toggle('slide', {direction: 'left'}, 600);
					//}
				}
				// remove the stylesheet added in header.jsp
				setTimeout(function(){
					$("link.oc-modal").remove();
					$("script.oc-modal").remove();
				}, 1000);
			});
		
		});
	</script>


<script>
var relatedTop;
</script>

		
	<link rel="stylesheet" href="/www/css/content-ribbon.css?v=20200708115223" />

	











<!-- Related Content -->




	<div class="related-content-wrapper">
		<div class="sector apart">
			
	    	<ul class="ribbon-row">
	    		    	
		    	

		    		
						
						
						
					














<li class="item-0 ribbon-col">
	<div class="item">
		
		<div class="title"><a  href="/article/3537635/google-chrome-os-plan.html">Google&#039;s grand Chrome OS plan is finally coming into focus</a></div>
	</div>
</li>


	<li class="ribbon-col ribbon-hed">
		<div class="item">
			<div class="title">
				RELATED STORIES
			</div>
		</div>
	</li>



					
		    	

		    		
						
						
						
					














<li class="item-1 ribbon-col">
	<div class="item">
		
		<div class="title"><a  href="/article/3545815/android-hardware-truth-google.html">The Android hardware truth Google won&#039;t tell you</a></div>
	</div>
</li>




	<li class="ribbon-col nativo-ribbon-item">
		<div class="title">
			<span class="item-eyebrow">SPONSORED BY <i>Advertiser Name Here</i></span>
			<a href="">Sponsored item title goes here as designed</a>
		</div>	
	</li>

					
		    	

		    		
						
						
						
					














<li class="item-2 ribbon-col">
	<div class="item">
		
		<div class="title"><a  href="/article/3235946/android-versions-a-living-history-from-1-0-to-today.html">Android versions: A living history from 1.0 to 11</a></div>
	</div>
</li>




					
		    	

		    		
						
						
						
					














<li class="item-3 ribbon-col">
	<div class="item">
		
		<div class="title"><a  href="/article/3562782/chrome-os-windows-apps.html">The wild thing about Windows apps on Chrome OS</a></div>
	</div>
</li>




					
		    	
		    	
		    	
					
					
						
						
						
							
							
							
							
							
							
							
							
							
							
						

































































					
				
		    </ul>
		</div>
	</div>

	<script>
	// Remove related content ribbon if device is less than tablet size (768px)
	if ($thm.deviceWidthLessThan($thm.deviceBreakpoints.tablet)) {
		$('.related-content-wrapper').remove();
	}

	</script>
	



<script>
var coreEdition = '';
var coreEditionAbbr = 'US';
var coreEditionDescription = 'United States';
//debugger;
$(document).ready(function() {
	$('.edition-picker').css("display",'inline-block');
	//reader selects edition from picker
	$("li.edition-picker-item a").on('click', function() {
		//debugger;
		//console.log("====edition-picker onclick - localeId from slug = " +  getIdFromSlug[$(this).attr("data-edition-name")]);
		var localeSlug = $(this).attr("data-edition-name");
		var selectedLocaleId = $(this).attr("data-edition-localeid");
		var dataLayer = window.dataLayer = window.dataLayer || [];
		dataLayer.push({
			'event': 'editionChange',
			'eventCategory':'Edition Change',
			'eventAction':localeSlug,
			'eventLabel':''
		});
		setSelectedLocale(selectedLocaleId); // save selection in cookie
		
	});
	var getDescFromId = getApolloLocaleDescMap();
	var localeDesc = "";
	//debugger;
	// if selectedLocale cookie exists, get locale
	if (typeof  getSelectedLocale() !== 'undefined' && getSelectedLocale() === getLocale()) { // get locale from cookie if available otherwise, use another locale source (from geolocation, url slug, etc.)
	 	countryCode = getSlugFromId[getSelectedLocale()];
	 	localeDesc = getDescFromId[getSelectedLocale()];
	} else {
		countryCode = getSlugFromId[getLocale()];
		localeDesc = getDescFromId[getLocale()];
	}
	// if countryCode is empty string at this point, it means getLocale() has localeId as 0 which is global locale.
	if (!countryCode) {
		countryCode = coreEditionAbbr; // country code for default global depends on brand (US for cio.com)
		localeDesc = coreEditionDescription;
	}

	// set current edition in header
	$("#current-edition").html(localeDesc.toUpperCase());
});
</script>

<script>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</script>

	
	



		
		













<div id="page-wrapper" class="page-wrapper">
	
	













<div id="skinAdTarget"></div>


			
		











	
	
	
	
	
	
	
	
	
	
	
	
	
	
	





	
	
 	


	
	<section role="main" itemscope itemtype="http://schema.org/Article">
	
		
		
		

		<article itemscope itemtype="http://schema.org/BlogPosting"  class="blog" >

		















<!-- Events Header -->

 
 
	
		
		
		
		
		
					    			
		
	
	
	
	
	

 
 
 
 
  
  
 
 












	
	
	
	
	
	
	
	
	
	
	
	
	
	
	


<!-- //end Events Header -->


	
	
	
	
	
	
		
	



	
		
	
	
		





















	
	
	
		
	
















<script src="/www/js/date-time-moments.js"></script>


	
		<script>
		$(document).ready(function() {
			var fullDate = "2020-07-14T09:15-0700";
			var timeDate = "";
			var dateFormat = "MMM D, YYYY h:mm a z";
			var dateFormatIntl = "D MMMM YYYY H:mm z";
			
			if ( document.getElementById("current-edition").textContent !== "UNITED STATES" ) {
				if ( document.getElementById("current-edition").textContent === "INDIA" ) {
					timeDate = moment(fullDate).tz('Asia/Calcutta').format(dateFormatIntl); // intl format eg: 10 AUGUST 2019 24 hours format no am/pm
				} else if ( document.getElementById("current-edition").textContent === "UNITED KINGDOM" ) {
					timeDate = moment(fullDate).tz('Europe/London').format(dateFormatIntl); // 24 hours format no am/pm
				} else if ( document.getElementById("current-edition").textContent === "ASEAN" ) {
					timeDate = moment(fullDate).tz('Asia/Singapore').format('D MMMM YYYY H:mm') + " SGT"; // 24 hours format no am/pm
				} else if ( document.getElementById("current-edition").textContent === "MIDDLE EAST" ) {
					timeDate = moment(fullDate).tz('Asia/Riyadh').format('D MMMM YYYY H:mm') + " AST"; // 24 hours format no am/pm
				} else if ( document.getElementById("current-edition").textContent === "AFRICA" ) {
					timeDate = moment(fullDate).tz('Africa/Johannesburg').format(dateFormatIntl); // 24 hours format no am/pm
				} else if ( document.getElementById("current-edition").textContent === "AUSTRALIA" ) {
					timeDate = moment(fullDate).tz('Australia/Sydney').format(dateFormatIntl); // 24 hours format no am/pm
				} else if ( document.getElementById("current-edition").textContent === "NEW ZEALAND" ) {
					timeDate = moment(fullDate).tz('Pacific/Auckland').format(dateFormatIntl); // 24 hours format no am/pm
				} else if ( document.getElementById("current-edition").textContent === "NETHERLANDS" ) {
					timeDate = moment(fullDate).tz('Europe/Amsterdam').format(dateFormatIntl); // 24 hours format no am/pm
				}
				else {
					timeDate = moment(fullDate).tz(Intl.DateTimeFormat().resolvedOptions().timeZone).format(dateFormatIntl); // 24 hours format no am/pm
				}
				document.querySelector(".format-date").textContent = timeDate;
			} else { // edition = UNITED STATES
				timeDate = moment(fullDate).tz('America/Los_Angeles').format(dateFormat); // US format eg: AUGUST 10, 2019 12 hour format
				document.querySelector(".format-date").textContent = timeDate;
			}
		});
		</script>
	
	
















	<style>
		nav.breadcrumbs { visibility: hidden; }
	</style>
	<script type="text/javascript">
	$(document).ready(function() {
		if ( document.getElementById("current-edition").textContent !== "UNITED STATES" ) {
			
	        var Obj = { 
	        	Centers: "Centre",
	        	Center: "Centre",
                Consumerization: "Consumerisation", 
                Fiber: "Fibre", 
                Internationalization: "Internationalisation",
                Licensing: "Licencing",
                Optimization: "Optimisation",
                Theater: "Theatre",
                Virtualization: "Virtualisation",
                Visualization: "Visualisation" 
            };
			
			if ( $("span").hasClass("primary-cat-name2") || $("span").hasClass("article-primary-cat") || $("span").hasClass("primary-cat-name") ) {
				var primaryCatName = "";
				var pluralCategory = document.querySelectorAll(".primary-cat-name2, .article-primary-cat, .primary-cat-name");
				
				pluralCategory = [].slice.call(pluralCategory);
				
				pluralCategory.forEach(function(element) {			
					primaryCatName = element.textContent.replace(/Centers|Center|Consumerization|Fiber|Internationalization|Licensing|Optimization|Theater|Virtualization|Visualization/, function(matched) { 
						return Obj[matched];
		            });			
					$(element).text(primaryCatName);
				});
			}
		} 
		$('nav.breadcrumbs').css('visibility','visible');
	});
	</script>




	
			












	
	
		<meta itemprop="keywords" content="android, mobile, microsoft, microsoft surface, google, mobile apps, web applications "/>
	







<header class='cat'>

	
	
	
	
	
	
	
	
	<nav class="breadcrumbs horiz">
		<ul itemscope itemtype="http://data-vocabulary.org/Breadcrumb">
			<li><a class="edition-link-url" href="/" itemprop="url"><span itemprop="title">Home</span></a></li>
			
				
				
					<li><a class="edition-link-url primary-cat-url" href="/category/operating-systems/" itemprop="url"><span class="primary-cat-name" itemprop="title">Operating Systems</span></a></li>
				
				
					<li><a class="edition-link-url" href="/category/android/" itemprop="url"><span class="article-primary-cat" itemprop="title">Android</span></a></li>
				
			
		</ul>
	</nav>
	
	
	
	
		<div class="blog-byline vcard author with-image" itemscope itemtype="http://schema.org/Person" itemprop="author">
			<div class="brand ">
				
				
					
					
						
							
							
							
							
						
















<a href="/author/JR-Raphael/" rel="author" title="JR Raphael"><img  class="bylineImage  imgId100759675 " src="https://images.idgesg.net/images/article/2018/05/jr-cw-150-2018-100759675-byline.png" width="34" width="34" alt="JR Raphael" itemprop="image" /></a>

					
					
				
				
				<div class="blog-branding-text">
					
					
					
					
					
					<div class="blog-title"><a href="/blog/android-intelligence/" class="edition-link-url">Android Intelligence</a></div>
					
					
					
						
							<p class="name" itemscope itemtype="http://schema.org/Person" itemprop="author">
								
								
								By <span class="fn" itemprop="name"><a rel="author" itemprop="url" href="/author/JR-Raphael/"><span itemprop="name">JR Raphael</span></a></span>, 
								
								<span class="cn-container">
									
								</span>
								
							  	 Contributing Editor, 
								
									
								












<span itemprop="publisher" itemscope itemtype="http://schema.org/Organization"><span class="publisher" itemprop="name">Computerworld</span><meta itemprop="url" content="https://www.computerworld.com" /><meta itemprop="logo" content="https://idge.staticworld.net/ctw/computerworld-logo300x300.png"/></span> 
								
								<span class="divider break">|</span>
								
								<span class="pub-date" class='break-date' itemprop="datePublished" 
								    content="2020-07-14T09:15-0700"><span class="format-date"></span>
									
								</span>
							</p>
							
							
																				
										
					
				</div>
			</div>
			
				<div class="about">
					<div class="about-title">About <span class="divider">|</span> <a href="/blog/android-intelligence/index.rss"><i class="ss-icon ss-social ss-rss"></i></a></div>
					<p>Not your average Android news — a diverse mix of advice, insight, and analysis with veteran Android journalist JR Raphael.</p>
				</div>
			
		</div>
	
	
	
	
	
	
	
		
			<div class="category">Android Intelligence Analysis</div>
		
		
	
	

	<h1 itemprop="headline">The Microsoft-Android transformation is about to affect us all</h1>
	
		<script>
		try {
			performance.mark("mark_headline_rendered");
		}
		catch(e) {
			console.log("Error saving performance mark -- this function may not be supported in this browser");
		}
		</script>
	
	
	
	
		<section class="deck viewability">
			<h3 itemprop="description">Blink and you might miss it, but Microsoft is little by little reshaping Google's mobile ecosystem for the better — and all signs suggest it's only getting started.</h3>
		</section>
	
	
	
	
	
	
	
	
			<div class="cat-social">
				
					
				















 



	

				

	
	
		
		
	



	
	


	


<div id="sharer" class="cat sidecar show blog">
<ul id="share-tool" class="expand">

	
		<li class="sosh">
			<a data-socialsite="Facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.computerworld.com%2Farticle%2F3566143%2Fmicrosoft-android-transformation.html" target="_blank">
				<img class="sidecar-icon" src="//idge.staticworld.net/images/facebook.svg" />
			</a>
		</li>	
	<li class="sosh">
		<a data-socialsite="Twitter" class="twit-hand" href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.computerworld.com%2Farticle%2F3566143%2Fmicrosoft-android-transformation.html&via=computerworld&text=The+Microsoft-Android+transformation+is+about+to+affect+us+all" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/twitter.svg" />
		</a>
	</li>
	<li class="sosh">
		<a data-socialsite="Linkedin" href="http://www.linkedin.com/shareArticle?url=https%3A%2F%2Fwww.computerworld.com%2Farticle%2F3566143%2Fmicrosoft-android-transformation.html&title=The+Microsoft-Android+transformation+is+about+to+affect+us+all" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/linkedin.svg" />
		</a>
	</li>	
	<li class="sosh hide">
			<a data-socialsite="Reddit" href="http://reddit.com/submit?url=https%3A%2F%2Fwww.computerworld.com%2Farticle%2F3566143%2Fmicrosoft-android-transformation.html&title=The+Microsoft-Android+transformation+is+about+to+affect+us+all" target="_blank">
				<img class="sidecar-icon" src="//idge.staticworld.net/images/reddit.svg" />
			</a>
	</li>	
	<li class="sosh hide">
		<a href="mailto:?Subject=The Microsoft-Android transformation is about to affect us all&Body=Check%20out%20this%20article%20from%20Computerworld%3A%20https%3A%2F%2Fwww.computerworld.com%2Farticle%2F3566143%2Fmicrosoft-android-transformation.html" target="_blank" rel="nofollow" id="email-icon">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/mail.svg" />	
		</a>
	</li>
	<li class="sosh hide print">
		<a href="javascript:window.print();">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/print.svg" />
		</a>
	</li>
	<li class="more">
		<div class="more-icon" onclick="document.getElementById('share-tool').className = 'expand';"></div>
	</li>




</ul>
</div>

<script type="text/javascript">
$(document).ready(function() {
	if (twitterHandle != "") {
		$("a[href*=via]").attr("href", function(_, href) {
			  return href.replace(/via=computerworld/, "via="+twitterHandle);
		});
	}
	
	//Add Social Share Event Tag in GTM - IDGMPM-17271
	$("a[data-socialsite]").click(function() {
		var dataLayer = window.dataLayer = window.dataLayer || [];
		dataLayer.push({
			'event': 'socialShare', 
		  	'eventCategory': 'Social Share',
		  	'eventAction': $(this).attr("data-socialsite"), 
		  	'eventLabel': window.document.title
		});
		
	});
});
</script>

<script type="text/javascript">
var isValidEmailAddress = isValidEmailAddress || function(emailAddress) {
    var pattern = new RegExp(/^[+a-zA-Z0-9._-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,5}$/i);
    return pattern.test(emailAddress);
};
function encodeQueryData(params) {
	var ret = [];
	for (var paramKey in params) {
		ret.push(encodeURIComponent(paramKey) + "=" + encodeURIComponent(params[paramKey]));
	}
	return ret.join("&");
}
</script>

			</div>
	
	
	

	
		
			
		
	
	
		
	
	
		
			<div class="ad viewability" id="viewabilityAdContainer">
				<div id="viewabilityAdUnit">
					
						
					





















	

		
			
			
			
			
			
			
				<div id="topleaderboard" class=" ad-container test">					
				</div>				
				<script type="text/javascript">
				consent.ads.queue.push(function(){
				
					IDG.GPT.addDisplayedAd("topleaderboard", "true");
					$('#topleaderboard').responsiveAd({screenSize:'971 1115', scriptTags: []});
                    IDG.GPT.log("Creating ad: topleaderboard - [971 1115]");
                    
				
				});
				</script>
			
		
	
 	
 
 
				</div>
			</div>
			
				<script src="/www/js/ads/stickyLb.js"></script>
				<script>
					var parallaxArgs = {
						topNavEl: 'oc-head',
						topNavIsSticky: true,
						leaderboadrdId: 'topleaderboard', 
						adContainer: 'viewabilityAdContainer',
						adUnit: 'viewabilityAdUnit',
						viewabilityTime: 10000
					}
				</script>
				
				
					
					
						<script>
						//console.log("%c Non-premium article or Insider logged in; wait to see if we have a skin ad before initializing sticky LB", 'background: #222; color: #bada55');

							function runStickyLb() {
								googletag.pubads().addEventListener('slotRenderEnded', function(event) {
									const slotId = event.slot.getSlotElementId();
									if (slotId == 'gpt-skin') {
										//console.log("%c slotId="+slotId, 'background: #222; color: #bada55');
										if (event.isEmpty) {
											//console.log("%c skin ad NOT running; okay to run sticky leaderboard", 'background: #222; color: #bada55');
											
											 parallaxLb(parallaxArgs);
										}
										else {
											//console.log("%c skin ad running; suppress sticky leaderboard and adjust other sticky page elements", 'background: #222; color: #bada55');
											document.querySelector("#oc-head").classList.remove("no-stick-important"); //make header sticky again
											if (document.querySelector("#collection-module-top") !== null) {//if there's a content collection, tuck it into the article body
												document.querySelector("#collection-module-top").classList.remove("stickfix");
												document.querySelector("#collection-module-top").style.position = "static";
											}
										}
									}
								});
							};
							try {
								IDG.GPT.googleCommandPush(runStickyLb);
							}
							catch(e){
								console.log('error determining if sticky LB can run: ' + e);
							}
							
						</script>
					
				
				
			
		
	
	
	
	
	
</header>




	<div class="constrain-970">
		
		
		
		
			
				<div class="lede-container">
					
					
					
						
						
							
				                
				                	
				                	
				                
				                
								
								
								
							
							
							
							
							<figure itemprop="image" itemscope itemtype="http://schema.org/ImageObject" class="hero-img">
								<meta itemprop="representativeOfPage" content="1" />
								<meta itemprop="height" content="800" />
								<meta itemprop="width" content="1200" />
					    		
					    		<img data-original="https://images.idgesg.net/images/article/2020/07/microsoft-android-100851580-large.jpg" class="lazy" loading="lazy" alt="Microsoft-Android" itemprop="contentUrl" itemprop="url" onload="try {performance.clearMarks('mark_primary_img_rendered'); performance.mark('mark_primary_img_rendered');}catch(e) {console.log('Error saving performance mark -- this function may not be supported in this browser');}"/>
					    		
						    		<script>
						    			try {
						    				performance.clearMarks("mark_primary_img_rendered");
											performance.mark("mark_primary_img_rendered");
						    			}
						    			catch(e) {
						    				console.log("Error saving performance mark -- this function may not be supported in this browser");
						    			}
									</script>
								
					    		<figcaption>
					    			
					    			
					    				<span class="credit" itemprop="copyrightHolder">
					    					
							    				
							    					<a href="https://www.computerworld.com/article/3566143" target="_blank" rel="nofollow">Microsoft/Google/JR Raphael</a>
							    				
							    				
						    				
				
							    			
							    				
							    				
							    				
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
							    				
							    				
												
											
									
										</span>
					    			
									
					    		</figcaption>
							</figure>
							
				
						
						
					
				</div>
			
			
		
	



<section class="epo cat-narrow" id="drr-top-ad">

	
	
	
	
	
	
		<div class="ad top-ad">
	
		
		
			
				
					
					
						
					
				
				
				
			





















	

		
			
			
			
			
			
			
				<div id="topimu" class="adunit ad-container test">					
				</div>				
				<script type="text/javascript">
				consent.ads.queue.push(function(){
				if($(window).width() >= 930) {
					IDG.GPT.addDisplayedAd("topimu", "true");
					$('#topimu').responsiveAd({screenSize:'971 1115', scriptTags: []});
                    IDG.GPT.log("Creating ad: topimu - [971 1115]");
                    
				}
				});
				</script>
			
		
	
 	
 
 
		
	
</div>
	
	
	
	
	
	
	
	
	
</section>

</div>







<div class="constrain-970">
	
</div>




<script src="/www/js/deal-modules.js"></script>

		
		



		<section class="bodee">

			
				
				
					












	
		





















<style>
	#drr-container figure.large.video {
		border-bottom: 0 none;
	}
	figure#page-lede.thm-gallery #bcplayer-gallery #bcplayer-gallery_ad > div {
		width: 100%;
		height: 100%;
		transition: all 0.5s ease;
	}
</style>
<style>
.jwplayer.jw-state-paused .jw-display {
	display: table !important;
	padding: 0;
}
.jwplayer .jw-display-icon-container {
    float: none;
    padding: 0;
    margin: 0;
}
.jw-flag-small-player .jw-display {
	padding-top: 0px;
}
.jwplayer .jw-display-icon-container .jw-icon-rewind {
	visibility: hidden;
}
.jwplayer .jw-display-icon-container .jw-icon-next {
	visibility: hidden;
}
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play path,
.jw-state-idle .jw-svg-icon-play path,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay path,
.jw-state-complete .jw-svg-icon-replay path {    
    display: none;
}
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play,
.jw-state-idle .jw-svg-icon-play,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay,
.jw-state-complete .jw-svg-icon-replay {
    background-size: contain;
    background-repeat: no-repeat;
    background-color: transparent;
    background-image: url(//idge.staticworld.net/idgtv/btn-play-default.svg);
    background-position: center center;
    bottom: 0;
    border-radius: 0;
    box-shadow: none;
    left: 0;
    margin: auto;
    right: 0;
    top: 0;
}
.jwplayer .jw-display-icon-container .jw-icon,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play,
.jw-state-idle .jw-svg-icon-play,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay,
.jw-state-complete .jw-svg-icon-replay {
    height: 81px;
    width: 78px;
}
</style>
<script>
$(document).ready(function() {
	var params = {
			def : "editfakeSideBar",
			geo : getLocale(),
			aid : 3566143
			}
		$.get(
			"/napi/tile",
			params,
			function(data, status, xhr) {
				//alert(article);
				$('#editorialfakesidebardiv').html(data);
			},
			"html");
	
	
	var params = {
			def : "sponsoredfakeSideBar",
			geo : getLocale(),
			aid : 3566143
			}
		$.get(
			"/napi/tile",
			params,
			function(data, status, xhr) {
				//alert(article);
				$('#sponsoredfakesidebardiv').html(data);
			},
			"html");
	
	
	var params = {
			def : "nativefakeSideBar",
			geo : getLocale(),
			aid : 3566143
			}
		$.get(
			"/napi/tile",
			params,
			function(data, status, xhr) {
				//alert(article);
				$('#nativefakesidebardiv').html(data);
			},
			"html");
	
});
</script>

	



	
	
	
	
		<div class="ad placement">
			
				
			





















	

		
			
			
			
				<script>
					var supLocaleEd = false;
					if (typeof countryCode !== 'undefined' && countryCode !== "" && countryCode === 'in' || (brandAbbrev === 'cio' && countryCode === 'nz')) {
						supLocaleEd = true;
					}
				</script>
				<!--  Begin inread -->
				<div id="inread" class=" ad-container">					
				</div>
				
				<script>
					if (supLocaleEd === true) {
						$("div#inread").remove();
					} else {
						consent.ads.queue.push(function(){
							IDG.GPT.addDisplayedAd("inread", "true");
							IDG.GPT.displayGoogleTagSlot('inread');
						});
					}
				</script>
				
				<!--  End inread -->	
			
			
			
			
		
	
 	
 
 
		</div>
	
	
	
	
	
	
	
	
		
		
			
			
				<div id="collection-module-top" class="some-toc" data-tracking-category="Collection Module - Top">
					
					
					<h3>Android Intelligence Analysis</h3>
					<ul>
					
						
							<li class="0 94 collection-item current">
								 
								
								<a  class="trackLink" href="/article/3566143/microsoft-android-transformation.html">The Microsoft-Android transformation is...</a>
							</li>
						
					
						
							<li class="1 94 collection-item">
								 
								
								<a  class="trackLink" href="/article/3564825/google-voice.html">Google Voice deserves your attention...</a>
							</li>
						
					
						
							<li class="2 94 collection-item">
								 
								
								<a  class="trackLink" href="/article/3563830/android-messaging.html"> This should be the future of Android...</a>
							</li>
						
					
						
							<li class="3 94 collection-item">
								 
								
								<a  class="trackLink" href="/article/3562782/chrome-os-windows-apps.html">The wild thing about Windows apps on...</a>
							</li>
						
					
						
							<li class="4 94 collection-item">
								 
								
								<a  class="trackLink" href="/article/3561622/android-11-additions.html">Android 11&#039;s most important additions</a>
							</li>
						
					
						
							<li class="5 94 collection-item" style="display:none">
								 
								
								<a  class="trackLink" href="/article/3561592/android-pro-subscription.html">Imagine an &#039;Android Pro&#039; subscription</a>
							</li>
						
					
						
							<li class="6 94 collection-item" style="display:none">
								 
								
								<a  class="trackLink" href="/article/3560973/android-ios-arguments.html">The key point most Android vs. iOS...</a>
							</li>
						
					
						
							<li class="7 94 collection-item" style="display:none">
								 
								
								<a  class="trackLink" href="/article/3545815/android-hardware-truth-google.html">The Android hardware truth Google won&#039;t...</a>
							</li>
						
					
						
							<li class="8 94 collection-item" style="display:none">
								 
								
								<a  class="trackLink" href="/article/3543760/google-pixel-phone-motion-sense.html">The Pixel phone&#039;s Motion Sense mystery</a>
							</li>
						
					
						
							<li class="9 94 collection-item" style="display:none">
								 
								
								<a  class="trackLink" href="/article/3542622/5g-android-flagships.html">Could 5G spell trouble for Android...</a>
							</li>
						
					
					</ul>
					
						<span class="collection-show-all btn" onclick="showAllCollectionItems()">Show More</span>
						<script type="text/javascript">
						function showAllCollectionItems() {
							$('#collection-module-top .collection-item').show();
							$('#collection-module-top .collection-show-all').hide();
							
							//When 'Show More' button is clicked, set the top
							$("#collection-module-top").css({"top": 15 +"px"});
						}
						</script>
					
				</div>
				
				
			
			<script>
				var dataLayer = window.dataLayer = window.dataLayer || [];
				dataLayer.push({
					'event': 'loadTopCollectionModule'
					});
			</script>
			
		
	
	
	
	
	
	
			
	
	
	
	
	
	
		
		
			
		
	
	
	
	
	
		
			
				
				
				
					
				
				
			
		
		
	
	
		
		
			<div id="drr-container" class='cat ' itemprop="articleBody">
		
		
		
		
	
		
			
			
				<p>I'm starting to feel like a broken record here, but man: Microsoft really is shaping up to be one of the most interesting forces in the Android ecosystem this year.</p><p>As the company gears up to release its first homegrown Android phone, the unusually dual-screened <a href="https://www.computerworld.com/article/3444499/microsoft-android-phone.html">Surface Duo</a>, we're seeing more and more signs of how it's bending Google's virtual neighborhood to suit its needs. And the effects of those efforts could end up having a surprisingly broad impact on Android — one that'd reach every corner of the ecosystem and all of us who use it, whether or not a Microsoft-branded device is involved.</p><p>That's exactly the case with Microsoft's latest Android-adjusting move, revealed in a recent <a href="https://medium.com/pwabuilder/microsoft-and-google-team-up-to-make-pwas-better-in-the-play-store-b59710e487" rel="noopener nofollow" target="_blank">low-profile post</a> on the site Medium. The article details a new collaborative plan between Google and Microsoft (better known as "The Hell Hath Frozen Over Amigos"). The goal is simultaneously simple and supremely ambitious: to make it easier for developers to create rich progressive web apps that'd be virtually indistinguishable from traditional Android apps in both function and presentation — and that'd exist in the Play Store, where you'd find and download 'em just like any regular ol' title. In fact, you'd probably never even know anything different was going on, and that's kinda the whole point.</p><p>Progressive web apps have actually been available in the Play Store for a while now, but this latest shift aims to make it easier than ever for developers to create 'em — and to do so using simple tools that'd bring more fully featured, native-app-like experiences into their offerings. Thanks to the new setup, Play-Store-hosted progressive web apps will soon be able to support app shortcuts, customized status bars, and advanced forms of notifications — all with minimal extra effort from their developers.</p><p>That last part is key — and what really clues us into how Microsoft is increasingly working to twist Android to its advantage and usher us all into its vision for a post-platform future.</p><aside class="fakesidebar"><strong>[Get level-headed knowledge in your inbox with JR's </strong><a href="https://www.androidintel.net" rel="noopener nofollow" target="_blank"><strong>Android Intelligence newsletter</strong></a><strong>. Tips, insights, and other tasty treats await!]</strong></aside><h2>Microsoft and the expanding Android ecosystem</h2><p>Before we get into the nitty-gritty of this, let me re-emphasize: The most important part of this whole effort is the fact that you'll almost certainly never be aware of it on any surface level. And, quite frankly, that's the beauty and the brilliance of it all. But understanding what's happening is still important if you want to keep tabs on the ever-shifting nature of our mobile-tech reality — and since you're reading a column called Android Intelligence, well, I'm assuming that you do.</p><aside class="nativo-promo nativo-promo-1 smartphone" id=""> </aside><p>So a progressive web app, in case that incredibly bland-sounding name doesn't ring a bell, is basically a special sort of packaging that allows a website to look and act like an app and emulate its more advanced functions. That means it can run offline (and thus feel fast, even when your network connection is not) as well as manage notifications, interact with local hardware, and exist in its own standalone app-like structure, with an icon in your app drawer and all the other standard fixins (to use the technical term).</p><div id="sponsoredfakesidebardiv" class="fakesidebar fakesidebar-auto fakesidebar-sponsored">
 </div><p>Unlike a traditional Android app, though, a progressive web app can run on a computer, too — <em>any </em>computer — in that same single form. And that means it's way easier and more economical for developers to maintain a single progressive web app and have that one version of their program run everywhere.</p><aside class="nativo-promo nativo-promo-1 tablet desktop" id=""> </aside><p>And if the end result is just as good as what you'd get with a native app — or close enough to seem <em>practically </em>the same, for most real-world purposes — then there's no real downside. It's a win-win-win, for developers, for gatekeepers like Microsoft and Google, and for us feline-impersonating land-people who rely on Android phones.</p><p>For Microsoft, the move means more and more apps could run in identical forms on both Windows and Android — and thus despite the fact that it's venturing into uncharted territory by fully embracing Android and steering folks into <a href="https://www.computerworld.com/article/3262705/how-to-create-a-complete-microsoft-experience-on-android.html">its own mini-ecosystem</a> <em>within</em> Google's universe, it can begin to offer a surprisingly consistent experience for anyone embracing a mix of Android and Windows (a fairly common combo for enterprise productivity and even general consumer use).</p><p>For Google, it means the amount of exceptional Android apps will only continue to grow and become more diverse. And remember, it isn't just about Android for Google, either; the company is equally interested in pushing <a href="https://www.computerworld.com/article/2893364/is-chrome-os-right-for-you.html">Chrome OS</a> forward, and the presence of <a href="https://www.computerworld.com/article/3234533/android-apps-for-chromebooks-the-essentials.html">Android apps on Chromebooks</a> is an important part of that picture. Remember, too, that Google recently started offering up progressive web apps <a href="https://www.computerworld.com/article/3537635/google-chrome-os-plan.html"><em>in place of</em> Android apps</a> in the Play Store on Chromebooks at times — a move that <a href="https://www.computerworld.com/article/3537635/">I theorized</a> could hint at eventual plans to turn the Play Store into a streamlined source of different types of apps for both Chrome OS <em>and</em> Android (which was a theory that a Google manager who works in that area <a href="https://twitter.com/dominickng/status/1250221738161397760" rel="nofollow">retweeted</a> with a party-face emoji and an applause emoji, incidentally; interpret as you will).</p><p>And for us, well, it means the benefits associated with all that stuff — the more consistent software experiences across multiple platforms, the more diverse options for software on Android, and so on — will be at our fingertips, no matter what types of devices we use in different areas of our lives.</p><aside class="nativo-promo nativo-promo-2 tablet desktop smartphone" id=""> </aside><p>And all of <em>that</em> is still only the start of the ways in which Microsoft is indirectly working to improve the state of affairs all across Android — and even further throughout the greater Google ecosystem.</p><h2>The broader Microsoft-Android landscape</h2><p>In the <a href="https://www.androidintel.net/15533/android-intelligence-newsletter-july-10-2020/" rel="noopener nofollow" target="_blank">latest issue of my newsletter</a>, I talked about how Microsoft's move to step up its Android software development game is giving me fresh optimism about the company's potential to shake up the <a href="https://www.computerworld.com/article/3531648/android-upgrades.html">sad state of Android upgrades</a>.</p><p>That's because Microsoft just days ago formed its own <a href="https://www.windowscentral.com/microsoft-brings-android-os-development-surface-duo-house-movial-acquisition" rel="noopener nofollow" target="_blank">in-house development team</a> to "handle post-launch software updates" and "add new features and experiences over time" for that upcoming Surface Duo device (and presumably also its successors). While it's slightly strange that Microsoft <em>didn't</em> have its own in-house software team for the product up 'til now — instead relying on externally contracted developers for the job — the fact that it's investing in establishing its own local squad for that purpose at this point, so close to the device's <a href="https://www.forbes.com/sites/ewanspence/2020/07/12/microsoft-surface-duo-android-google-compatibility-partnership/#2b005c174bd2" rel="noopener nofollow" target="_blank">likely debut</a>, makes me hopeful the reason is at least in part that the company wants to be prepared to handle post-sales software support properly.</p><p>It's something I've been hopeful of before, albeit in a much more guarded way. As I wrote <a href="https://www.computerworld.com/article/3542508/">earlier this year</a>:</p><blockquote>
<p>Outside of Google and its own Pixel line of products, most Android phone-makers do a consistently terrible job of sending out software updates to their users. The data <a href="https://www.computerworld.com/article/3530002/android-10-upgrade-report-card.html">says it all</a>, and despite heavily hyped narratives to the contrary, things <a href="https://www.computerworld.com/article/3531648/">aren't really getting much better</a> — not by any meaningful measure.</p>
<p>The underlying reason is simple: Outside of Google, most device-makers don't have the motivation to make timely and ongoing post-sales software support a priority. I mean, think about it: They make their money mostly by selling you hardware. Software updates require time and resources, and the companies doing all that legwork don't get anything tangible back in return. If anything, updates arguably work <em>against </em>most device-makers' interests, as getting phone-improving updates early and often makes your current phone seem consistently new, fresh, and current enough to keep using.</p>
<p>And what do the companies making those devices want you to do? Yup, you guessed it: buy new phones as frequently as possible.</p>
</blockquote><p>Right now, Google really is the sole exception to that rule within the realm of Android — the only company for whom selling you hardware is less of a primary goal and more of a way to draw you in deeper to its software-and-service-driven primary business. Well, guess what other company also fits that same description? Yes, indeedly: none other than everyone's favorite (or maybe sometimes not-so-favorite) Windows warrior.</p><p>Factor in the fact that Microsoft is also the sole Android-involved company outside of Google that has actual experience at providing timely software updates on any large scale — not to mention a history of treating that process as a priority — and you can see why, now more than ever, I'm feeling optimistic about how Microsoft could potentially reshape the expectations around Android upgrades in a way Google by itself has never managed to do.</p><p>And if all of that weren't enough, let's not forget all the ways Microsoft has been indirectly improving Google's Chrome browser lately as well. From <a href="https://www.cnet.com/news/google-chrome-will-gobble-less-memory-on-windows-10-following-microsoft-edge/" rel="noopener nofollow" target="_blank">memory handling</a> to <a href="https://www.theverge.com/2020/1/27/21083299/microsoft-google-chrome-tab-management-chromium-improvements-feature" rel="noopener nofollow" target="_blank">tab management</a> and smaller touches such as <a href="https://www.xda-developers.com/google-chrome-microsoft-edge-drag-drop-file-fix/" rel="noopener nofollow" target="_blank">file drag-and-drop behavior</a> and in-browser <a href="https://www.theverge.com/2020/5/28/21273934/microsoft-google-chrome-edge-chromium-spellcheck-improvements" rel="noopener nofollow" target="_blank">spellcheck effectiveness</a>, the company once known as Google's archenemy is offering up lots of its engineering efforts to enhance the lives of Chrome users (as a side effect of the fact that its own Edge browser now uses the same Google-managed code base as Chrome, but regardless).</p><p>And that's to say nothing of the fact that Google's on the brink of unveiling actual <a href="https://www.computerworld.com/article/3562782/chrome-os-windows-apps.html">Windows app support for Chromebooks</a> in the enterprise — a move that'll further break down the remaining barriers between Microsoft's universe and Google's domain. Truly, for anyone paying attention, the creeping (and generally quite positive!) Microsoft influence on Google ecosystems is one of the biggest mobile-tech stories of 2020.</p><p>Only time will tell whether Microsoft's first Android phone ends up being worth owning, all in all, or whether it proves to be a compromise-laden flop. But in a way, it almost doesn't matter — at least, not in any big-picture sense. The story here is really less about that one device and more about the ongoing Google ecosystem <em>investments</em> that product and the strategies around it are causing Microsoft to make.</p><p>Two once-sworn enemies, working together in user-serving harmony. What a weird, wild world we live in.</p><p><i>Sign up for <a href="https://www.androidintel.net" rel="noopener nofollow" target="_blank">my weekly newsletter</a> to get more practical tips, personal recommendations, and plain-English perspective on the news that matters.</i></p><figure class="large "><a href="https://www.androidintel.net" rel="noopener nofollow" target="_blank"><img border="0" alt="AI Newsletter" width="700" height="63" data-imageid="100774017" data-original="https://images.idgesg.net/images/article/2018/09/ai-newsletter-new2-100774017-large.jpg" class="lazy" loading="lazy"/></a></figure><p><strong>[<a href="https://www.computerworld.com/video/series/8536/android">Android Intelligence videos at Computerworld</a>]</strong></p>
			
		
		
	
		
		
			
		
		
		
		
			
			
			
			










<div class="end-note">
	
		
	











	
	
	
	
	
	
	
	
	
	
	
	
	
	
	


</div>
		
		
	</div>
	
		<script>
			try {
				performance.mark("mark_article_body_rendered");
			}
			catch(e) {
				console.log("Error saving performance mark -- this function may not be supported in this browser");
			}
		</script>
	
	
	
		
		
		
	
	
	
	
	
	
	
	
	    <div class="apart-alt tags">
	    <span class="related">Related: </span>
	    <ul>
			
				<li><a class="edition-link-url primary-cat-url2" href="/category/android"><span class="primary-cat-name2">Android</span></a></li>
			
				<li><a class="edition-link-url primary-cat-url2" href="/category/mobile"><span class="primary-cat-name2">Mobile</span></a></li>
			
				<li><a class="edition-link-url primary-cat-url2" href="/category/microsoft"><span class="primary-cat-name2">Microsoft</span></a></li>
			
				<li><a class="edition-link-url primary-cat-url2" href="/category/microsoft-surface"><span class="primary-cat-name2">Microsoft Surface</span></a></li>
			
				<li><a class="edition-link-url primary-cat-url2" href="/category/google"><span class="primary-cat-name2">Google</span></a></li>
			
				<li><a class="edition-link-url primary-cat-url2" href="/category/mobile-apps"><span class="primary-cat-name2">Mobile Apps</span></a></li>
			
				<li><a class="edition-link-url primary-cat-url2" href="/category/web-applications"><span class="primary-cat-name2">Web Applications</span></a></li>
			 
			
				
				
					
				
					
			
	    </ul>
	   
		</div>
	
	
	
	
	
	
	
	
	
			
	   		












	
	
		<div class="byline vcard author end-byline">	
			<div class="author-info">
					<p class="bio">Contributing Editor <a href="https://www.jrstart.com" target="_blank">JR Raphael</a> serves up tasty morsels about the human side of technology. Hungry for more? Join him <a href="https://twitter.com/jrraphael" target="_blank">on Twitter</a> or sign up for <a href="https://www.androidintel.net" target="_blank">his weekly newsletter</a> to get fresh tips and insight in your inbox every Friday.</p>
			</div><!-- end .author-info -->
			<div class="brand-social">
				<div class="follow-text">Follow</div>
				<ul class="social-links">
					<li>
						<a href="/author/JR-Raphael/">
							<i class="ss-icon ss-user"></i>
						</a>
					</li>
					
					
						<li>
							<a href="https://twitter.com/JRRaphael" class="twitter-follow" target="_blank">
								<i class="ss-icon ss-social ss-twitter"></i>
							</a>
						</li>
					
					
					
					
						<li>
							<a href="/author/JR-Raphael/index.rss" class="rss">
								<i class="ss-icon ss-social ss-rss"></i>
							</a>
						</li>
					
				</ul>
			</div>			
		</div>
	



	   		
	   		
			
	
	
	
	
		












	
	


<script>
//set business unit / publisher: US / global is default
var contentCopyright = "IDG Communications, Inc.";
var contentEdition = "";
// if there's an article locale ID, use that to get the business unit / publisher for copyright (empty string is global)
if ( contentEdition != "" || contentEdition != null ) {
	// get locale slug of article (contentEdition)
	 contentEdition = "";
	if (contentEdition === 'us') {
		contentCopyright = "IDG Communications, Inc.";
	}
	if (contentEdition === 'asean') {
		contentCopyright = "IDG Communications, Inc.";
	}
	if (contentEdition === 'mideast' || contentEdition === 'middle-east') {
		contentCopyright = "";
	}
	if (contentEdition === 'uk') {
		contentCopyright = "IDG Communications Ltd.";
	}
	if (contentEdition === 'au') {
		contentCopyright = "IDG Communications. ABN 14 001 592 650";
	}
	if (contentEdition === 'nz') {
		contentCopyright = "IDG Communications. ABN 14 001 592 650";
	}
	if (contentEdition === 'in') {
		contentCopyright = "IDG Media Private Ltd";
	}
	if (contentEdition === 'nl') {
		contentCopyright = "IDG Benelux";
	}
}
$(document).ready(function() {
	if (contentCopyright != null && contentCopyright != "") {
		document.querySelector("span.ccbu").textContent = contentCopyright;
	}
});
</script>


	<p class="content-copy">Copyright &copy; 2020 <span class="ccbu">IDG Communications, Inc.</span></p>

	
		 
	
	
	
	
	
		
		
	

















	 
	




<script>
$("body").on('click', 'a[data-product-id]', function() {
	var e = e || window.event;
	var dataLayer = window.dataLayer = window.dataLayer || [];
	var prodName = $(this).attr("data-product-name");
	prodName = prodName.replace("\\'","'"); // to counter the effects of over-escaping
	
	if ( $(this).parents('.slideshow').length > 0 ) {
		var productLinkPosition = "Slideshow";
	} else if ( $(this).parents('.emo-sb').length > 0 ) {
		var productLinkPosition = "Product Sidebar";
	} else if ( $(this).parents('.at-a-glance.top').length > 0 ) {
		var productLinkPosition = "AAG Top";
	} else if ( $(this).parents('.at-a-glance').length > 0 ) {
		var productLinkPosition = "AAG Bottom";
	} else if ( $(this).parents('.quick-hits.medium').length > 0 ) {
		var productLinkPosition = "Quick Hit Medium";
	} else if ( $(this).parents('.quick-hits').length > 0 ) {
		var productLinkPosition = "Quick Hit Full";
	} else if ( $(this).parents('.product-chart').length > 0 ) {
		var productLinkPosition = "Product Chart";
	} else if ( $(this).parents('.emo-list').length > 0 ) {
		var productLinkPosition = "Product List";
	} else {
		var productLinkPosition = "Body Text";
	}
	
	dataLayer.push({
		'event': 'affiliateLink', 
	  	'eventCategory': 'Affiliate Link', // Hardcoded, not dynamic
	  	'eventAction': 'Click', // Hardcoded, not dynamic
	  	'eventLabel': ''+e.target+'', // The URL the affiliate link leads to
	  	'productVendor': $(this).attr("data-bkvndr"), // The vendor of the product
	  	'productManufacturer': $(this).attr("data-bkmfr"), // The manufacturer of the product
	  	'productName': prodName, // The name of the product
	  	'productId': $(this).attr("data-product-id"), // The ID of the product
	  	'productLinkPosition': productLinkPosition // location of product link (Product Sidebar, Product Chart, etc.)
	});
	
	window.permutive.track('AffiliateLinkClick', {
	    category: $(this).attr("data-bkc"),
	    name: prodName,
	    manufacturer: $(this).attr("data-bkmfr"),
	    vendor: $(this).attr("data-bkvndr")
	});
	
});
</script>


	<script>
$("#drr-container a:not('[data-product-id]')").on('click',function(e){
	var dataLayer = window.dataLayer = window.dataLayer || [];
	
	var $clickEl = $(this);
	var clickUrl = $clickEl.attr("href");
	var clickParentsUntilDrr = $clickEl.parentsUntil("#drr-container");
	var clickText = $clickEl.text().trim();
	var linkLocation;
	var linkType;
	var regex = new RegExp("cio.com/|csoonline.com/|computerworld.com/|itnews.com/|itworld.com/|infoworld.com/|networkworld.com/|javaworld.com/|techconnect.com/|techhive.com/|macworld.com/|pcworld.com/|greenbot.com/|gamestar.com/|idginsiderpro.com/|idgesg.net/", "i");
	
	if (clickParentsUntilDrr.hasClass("fakesidebar")) {
		linkLocation = "FSB";
	}
	else if (clickParentsUntilDrr.hasClass("end-note")) {
     	 linkLocation = "End Note";
   }
	else {
		linkLocation = "Body";
	}
	
	if (regex.test(clickUrl)) {
	      linkType = "Internal";
	    }
	else {
		linkType = "External";
	}
		
	
	dataLayer.push({
		'event': 'editBodyLink', 
	  	'eventCategory': 'Editorial Body Links',
	  	'eventAction': linkType,
	  	'eventLabel': linkLocation+" | "+clickText+" | "+clickUrl
	});
});
</script>


<script>
$("#drr-top-ad .related-promo-wrapper .title > a").on('click',function(e){
	var dataLayer = window.dataLayer = window.dataLayer || [];
	
	var $clickEl = $(this);
	var clickUrl = $clickEl.attr("href");
	var clickText = $clickEl.text().trim();
	var linkLocation = "Promo";		
	
	dataLayer.push({
		'event': 'promoModuleLink', 
	  	'eventCategory': 'Promotion module',
	  	'eventAction': 'Click',
	  	'eventLabel': linkLocation+" | "+clickText+" | "+clickUrl
	});
});
</script>
	

	
	
	
	
	
	












	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
















<div id="collection-module-bottom" class="six-column item-carousel clearfix" data-tracking-category="Content Collection - Bottom">
	<div class="collection-header">
		
		<h3>Android Intelligence Analysis</h3>
		<div class="carousel-nav">	
			
			<div class="carousel-nav-nums"></div>
			
		</div>
	</div>
		<div class="items carousel-items clearfix">
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3566143/microsoft-android-transformation.html">
							    <img  class="small.3x2Image  imgId100851580 " data-lazy="https://images.idgesg.net/images/article/2020/07/microsoft-android-100851580-small.3x2.jpg" alt="Microsoft-Android" />
							</a>
						</figure>
						<div class="item-current">Currently reading</div>
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3566143/microsoft-android-transformation.html">The Microsoft-Android transformation is about to affect us...</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3564825/google-voice.html">
							    <img  class="small.3x2Image  imgId100850872 " data-lazy="https://images.idgesg.net/images/article/2020/07/google-voice-100850872-small.3x2.jpg" alt="Google Voice" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3564825/google-voice.html">Google Voice deserves your attention (again)</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3563830/android-messaging.html">
							    <img  class="small.3x2Image  imgId100849698 " data-lazy="https://images.idgesg.net/images/article/2020/06/android-messaging-100849698-small.3x2.jpg" alt="Android Messaging" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3563830/android-messaging.html"> This should be the future of Android messaging</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3562782/chrome-os-windows-apps.html">
							    <img  class="small.3x2Image  imgId100849060 " data-lazy="https://images.idgesg.net/images/article/2020/06/google-chrome-os-windows-apps-100849060-small.3x2.jpg" alt="Google Chrome OS, Windows Apps" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3562782/chrome-os-windows-apps.html">The wild thing about Windows apps on Chrome OS</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3561622/android-11-additions.html">
							    <img  class="small.3x2Image  imgId100832680 " data-lazy="https://images.idgesg.net/images/article/2020/02/android-11-100832680-small.3x2.jpg" alt="Android 11" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3561622/android-11-additions.html">Android 11&#039;s most important additions</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3561592/android-pro-subscription.html">
							    <img  class="small.3x2Image  imgId100848242 " data-lazy="https://images.idgesg.net/images/article/2020/06/google-android-pro-subscription-100848242-small.3x2.jpg" alt="google android pro subscription" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3561592/android-pro-subscription.html">Imagine an &#039;Android Pro&#039; subscription</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3560973/android-ios-arguments.html">
							    <img  class="small.3x2Image  imgId100847940 " data-lazy="https://images.idgesg.net/images/article/2020/06/android-ios-arguments-100847940-small.3x2.jpg" alt="Android iOS Arguments" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3560973/android-ios-arguments.html">The key point most Android vs. iOS arguments miss</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3545815/android-hardware-truth-google.html">
							    <img  class="small.3x2Image  imgId100843215 " data-lazy="https://images.idgesg.net/images/article/2020/05/android-tablet-100843215-small.3x2.jpg" alt="Android Tablet" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3545815/android-hardware-truth-google.html">The Android hardware truth Google won&#039;t tell you</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3543760/google-pixel-phone-motion-sense.html">
							    <img  class="small.3x2Image  imgId100842410 " data-lazy="https://images.idgesg.net/images/article/2020/05/google-pixel-phone-100842410-small.3x2.jpg" alt="Google Pixel Phone" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3543760/google-pixel-phone-motion-sense.html">The Pixel phone&#039;s Motion Sense mystery</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3542622/5g-android-flagships.html">
							    <img  class="small.3x2Image  imgId100841664 " data-lazy="https://images.idgesg.net/images/article/2020/05/5g-android-flagship-100841664-small.3x2.jpg" alt="5G Android Flagship" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3542622/5g-android-flagships.html">Could 5G spell trouble for Android flagships?</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3539018/iphone-se-pixel-4a.html">
							    <img  class="small.3x2Image  imgId100839156 " data-lazy="https://images.idgesg.net/images/article/2020/04/iphone-se-pixel-4a-100839156-small.3x2.jpg" alt="iPhone SE, Pixel 4a" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3539018/iphone-se-pixel-4a.html">The problem with the &#039;iPhone SE killed the Pixel 4a&#039;...</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3539557/motorola-edge.html">
							    <img  class="small.3x2Image  imgId100839481 " data-lazy="https://images.idgesg.net/images/article/2020/04/motorola-edge-launch-100839481-small.3x2.jpg" alt="Motorola Edge Kaunch" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3539557/motorola-edge.html">The two words Motorola doesn&#039;t want you to read</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3541234/google-meet.html">
							    <img  class="small.3x2Image  imgId100840239 " data-lazy="https://images.idgesg.net/images/article/2020/04/google-messaging-services-100840239-small.3x2.jpg" alt="Google Messaging Services" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3541234/google-meet.html">Google Meet’s messy message</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3542508/android-question.html">
							    <img  class="small.3x2Image  imgId100840994 " data-lazy="https://images.idgesg.net/images/article/2020/05/android-question-100840994-small.3x2.jpg" alt="android question" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3542508/android-question.html">The most interesting Android question of the year</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3538236/google-apple-contact-tracing.html">
							    <img  class="small.3x2Image  imgId100838707 " data-lazy="https://images.idgesg.net/images/article/2020/04/google-apple-contact-tracing-100838707-small.3x2.jpg" alt="Google-Apple Contact Tracing" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3538236/google-apple-contact-tracing.html">6 make-or-break questions about Google and Apple&#039;s...</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3535333/foldable-phones.html">
							    <img  class="small.3x2Image  imgId100837333 " data-lazy="https://images.idgesg.net/images/article/2020/04/foldable-phone-100837333-small.3x2.jpg" alt="Foldable Phone" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3535333/foldable-phones.html">I&#039;ve finally figured out why foldable phones actually exist</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3533349/google-pixel-5-phone.html">
							    <img  class="small.3x2Image  imgId100835920 " data-lazy="https://images.idgesg.net/images/article/2020/03/google-pixel-5-phone-100835920-small.3x2.jpg" alt="Google Pixel 5 Phone" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3533349/google-pixel-5-phone.html">Why the Pixel 5 just got interesting</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3531648/android-upgrades.html">
							    <img  class="small.3x2Image  imgId100834833 " data-lazy="https://images.idgesg.net/images/article/2020/03/android-upgrades-100834833-small.3x2.jpg" alt="Android Upgrades" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3531648/android-upgrades.html">Are Android upgrades actually improving? It&#039;s complicated</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3530002/android-10-upgrade-report-card.html">
							    <img  class="small.3x2Image  imgId100834228 " data-lazy="https://images.idgesg.net/images/article/2020/03/android-10-upgrade-report-card-100834228-small.3x2.jpg" alt="Android 10 Upgrade Report Card" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3530002/android-10-upgrade-report-card.html">Android 10 Upgrade Report Card: Progress is relative</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3528880/phone-billboards.html">
							    <img  class="small.3x2Image  imgId100833375 " data-lazy="https://images.idgesg.net/images/article/2020/02/phone-billboards-100833375-small.3x2.jpg" alt="Phone Billboards" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3528880/phone-billboards.html">Attention, phone-makers: Our devices aren&#039;t your billboards</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3528210/android-11-takeaways.html">
							    <img  class="small.3x2Image  imgId100832680 " data-lazy="https://images.idgesg.net/images/article/2020/02/android-11-100832680-small.3x2.jpg" alt="Android 11" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3528210/android-11-takeaways.html">The 11 most interesting takeaways from Android 11 (so far)</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3526601/google-samsung.html">
							    <img  class="small.3x2Image  imgId100832061 " data-lazy="https://images.idgesg.net/images/article/2020/02/google-samsung-100832061-small.3x2.jpg" alt="Google / Samsung" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3526601/google-samsung.html">Hey, Google: Maybe it&#039;s time to take a lesson from Samsung</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3526431/android-innovations.html">
							    <img  class="small.3x2Image  imgId100831715 " data-lazy="https://images.idgesg.net/images/article/2020/02/android-innovations-100831715-small.3x2.jpg" alt="Android Innovations" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3526431/android-innovations.html">Beware of the coming Android &#039;innovations&#039;</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3519689/google-blackberry.html">
							    <img  class="small.3x2Image  imgId100762473 " data-lazy="https://images.idgesg.net/images/article/2018/06/blackberry-android-upgrade-100762473-small.3x2.jpg" alt="BlackBerry Android Upgrade" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3519689/google-blackberry.html">Could Google carry the BlackBerry torch?</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3518402/android-google-microsoft.html">
							    <img  class="small.3x2Image  imgId100828313 " data-lazy="https://images.idgesg.net/images/article/2020/01/android-google-microsoft-100828313-small.3x2.jpg" alt="Android: Google, Microsoft" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3518402/android-google-microsoft.html">Move over, Google: Microsoft&#039;s the new Android trailblazer</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3516145/google-hangouts-2020.html">
							    <img  class="small.3x2Image  imgId100828155 " data-lazy="https://images.idgesg.net/images/article/2020/01/google-hangouts-2020-100828155-small.3x2.jpg" alt="Google Hangouts 2020" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3516145/google-hangouts-2020.html">Welcome to Hangouts hell</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3514999/samsung-selling-data.html">
							    <img  class="small.3x2Image  imgId100827556 " data-lazy="https://images.idgesg.net/images/article/2020/01/samsung-selling-data-100827556-small.3x2.jpg" alt="Samsung Selling Data" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3514999/samsung-selling-data.html">Galaxy users, take note: Samsung&#039;s probably selling your...</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3513992/google-2020.html">
							    <img  class="small.3x2Image  imgId100826806 " data-lazy="https://images.idgesg.net/images/article/2020/01/google-2020-worry-100826806-small.3x2.jpg" alt="Google 2020 Worry" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3513992/google-2020.html">Google&#039;s greatest worry in 2020 isn&#039;t what you&#039;d expect</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3490386/google-assistant-advancements.html">
							    <img  class="small.3x2Image  imgId100824533 " data-lazy="https://images.idgesg.net/images/article/2019/12/google-assistant-superpower-100824533-small.3x2.jpg" alt="Google Assistant Superpower" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3490386/google-assistant-advancements.html">The glaring gap in Google&#039;s Assistant advancements</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3512657/android-trends-2020.html">
							    <img  class="small.3x2Image  imgId100745726 " data-lazy="https://images.idgesg.net/images/article/2018/01/android-trends-100745726-small.3x2.jpg" alt="Android Trends" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3512657/android-trends-2020.html">7 Android trends to watch in 2020</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3489464/google-killed-services-2019.html">
							    <img  class="small.3x2Image  imgId100821045 " data-lazy="https://images.idgesg.net/images/article/2019/12/google-killed-services-2019-100821045-small.3x2.jpg" alt="Google Killed Services 2019" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3489464/google-killed-services-2019.html">Google&#039;s worst kills of 2019</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3487702/google-ceo-shakeup.html">
							    <img  class="small.3x2Image  imgId100820273 " data-lazy="https://images.idgesg.net/images/article/2019/12/google-alphabet-ceo-100820273-small.3x2.jpg" alt="Google / Alphabet CEO" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3487702/google-ceo-shakeup.html">6 smart things to think over with Google&#039;s leadership...</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3453381/motorola-razr-foldable.html">
							    <img  class="small.3x2Image  imgId100817798 " data-lazy="https://images.idgesg.net/images/article/2019/11/motorola-razr-2019-100817798-small.3x2.jpg" alt="Motorola Razr 2019" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3453381/motorola-razr-foldable.html">Motorola&#039;s new Razr gives me hope for the future of...</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3451983/pixel-4-standby-power.html">
							    <img  class="small.3x2Image  imgId100816786 " data-lazy="https://images.idgesg.net/images/article/2019/11/pixel-4-standby-power-100816786-small.3x2.jpg" alt="Pixel 4 Standby Power" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3451983/pixel-4-standby-power.html">The Pixel 4&#039;s power-plunging puzzle</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3446162/pixel-4-google-hardware.html">
							    <img  class="small.3x2Image  imgId100814418 " data-lazy="https://images.idgesg.net/images/article/2019/10/google-pixel-4-100814418-small.3x2.jpg" alt="Google Pixel 4" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3446162/pixel-4-google-hardware.html">How the Pixel 4 epitomizes Google&#039;s hardware gamble</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3449599/google-hardware.html">
							    <img  class="small.3x2Image  imgId100816115 " data-lazy="https://images.idgesg.net/images/article/2019/10/google-hardware-100816115-small.3x2.jpg" alt="Google Hardware" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3449599/google-hardware.html">The most interesting thing Google didn&#039;t announce at its...</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3447704/pixel-4-predicament.html">
							    <img  class="small.3x2Image  imgId100815383 " data-lazy="https://images.idgesg.net/images/article/2019/10/pixel-4-100815383-small.3x2.jpg" alt="Pixel 4" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3447704/pixel-4-predicament.html">The Pixel 4&#039;s perplexing predicament</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3446700/pixel-4-phone.html">
							    <img  class="small.3x2Image  imgId100815118 " data-lazy="https://images.idgesg.net/images/article/2019/10/google-pixel-4-phone-100815118-small.3x2.jpg" alt="Google Pixel 4 Phone" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3446700/pixel-4-phone.html">5 big buts about the Pixel 4 phone</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3441076/pixel-watch.html">
							    <img  class="small.3x2Image  imgId100811943 " data-lazy="https://images.idgesg.net/images/article/2019/09/google-pixel-watch-100811943-small.3x2.jpg" alt="Google Pixel Watch" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3441076/pixel-watch.html">The secret ingredients that could make a Pixel Watch matter</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3438326/google-assistant-additions.html">
							    <img  class="small.3x2Image  imgId100810838 " data-lazy="https://images.idgesg.net/images/article/2019/09/google-assistant-100810838-small.3x2.jpg" alt="Google Assistant" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3438326/google-assistant-additions.html">4 Google Assistant additions worth watching</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3444499/microsoft-android-phone.html">
							    <img  class="small.3x2Image  imgId100813266 " data-lazy="https://images.idgesg.net/images/article/2019/10/microsoft-surface-duo-android-phone-100813266-small.3x2.jpg" alt="Microsoft Surface Duo Android Phone" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3444499/microsoft-android-phone.html">9 critical questions about Microsoft&#039;s first Android phone</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3434100/google-smart-displays.html">
							    <img  class="small.3x2Image  imgId100809155 " data-lazy="https://images.idgesg.net/images/article/2019/08/google-smart-displays-100809155-small.3x2.jpg" alt="Google Smart Displays" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3434100/google-smart-displays.html">7 ways Google&#039;s Smart Displays could get smarter</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3433262/android-10-end-of-whimsy.html">
							    <img  class="small.3x2Image  imgId100808924 " data-lazy="https://images.idgesg.net/images/article/2019/08/android-branding-100808924-small.3x2.jpg" alt="Android Branding" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3433262/android-10-end-of-whimsy.html">Android 10 and the end of whimsy</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3429573/google-pixel-4-phone-side-effect.html">
							    <img  class="small.3x2Image  imgId100807298 " data-lazy="https://images.idgesg.net/images/article/2019/08/google-pixel-4-phone-side-effect-100807298-small.3x2.jpg" alt="Google Pixel 4 Phone Side Effect" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3429573/google-pixel-4-phone-side-effect.html">The unexpected side effect of Google&#039;s Pixel 4 phone</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3428997/google-pixel-4-radar.html">
							    <img  class="small.3x2Image  imgId100806880 " data-lazy="https://images.idgesg.net/images/article/2019/07/google-pixel-4-project-soli-radar-100806880-small.3x2.jpg" alt="Google Pixel 4 - Project Soli Radar" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3428997/google-pixel-4-radar.html">How Google&#039;s Pixel 4 radar system could be more than a...</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3411932/silly-smartphone-design-shift.html">
							    <img  class="small.3x2Image  imgId100806621 " data-lazy="https://images.idgesg.net/images/article/2019/07/silly-smartphone-design-shift-100806621-small.3x2.jpg" alt="Silly Smartphone Design Shift" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3411932/silly-smartphone-design-shift.html">Here comes the next silly smartphone design shift</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3409976/apple-google-copycat-conundrum.html">
							    <img  class="small.3x2Image  imgId100802075 " data-lazy="https://images.idgesg.net/images/article/2019/07/apple-google-copying-100802075-small.3x2.jpg" alt="Apple Google Copying" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3409976/apple-google-copycat-conundrum.html">Apple, Google, and the copycat conundrum</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3404206/googles-officially-done-making-its-own-tablets.html">
							    <img  class="small.3x2Image  imgId100776773 " data-lazy="https://images.idgesg.net/images/article/2018/10/google-pixel-slate-100776773-small.3x2.jpg" alt="Google Pixel Slate" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3404206/googles-officially-done-making-its-own-tablets.html">Google&#039;s officially done making its own tablets</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3403332/downfall-virtual-assistant.html">
							    <img  class="small.3x2Image  imgId100799639 " data-lazy="https://images.idgesg.net/images/article/2019/06/virtual-assistant-100799639-small.3x2.jpg" alt="Virtual Assistant" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3403332/downfall-virtual-assistant.html">The downfall of the virtual assistant (so far)</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3402019/google-project-soli-pixel-4.html">
							    <img  class="small.3x2Image  imgId100799127 " data-lazy="https://images.idgesg.net/images/article/2019/06/google-project-soli-pixel-4-100799127-small.3x2.jpg" alt="Google Project Soli Pixel 4" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3402019/google-project-soli-pixel-4.html">Project Soli in depth: How radar-detected gestures could...</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3401480/smartphone-bezel-obsession.html">
							    <img  class="small.3x2Image  imgId100798917 " data-lazy="https://images.idgesg.net/images/article/2019/06/smartphone-bezel-obsession-100798917-small.3x2.jpg" alt="Smartphone Bezels" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3401480/smartphone-bezel-obsession.html">The enduring absurdity of our smartphone bezel obsession</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3399865/amazon-mobile-carrier.html">
							    <img  class="small.3x2Image  imgId100798159 " data-lazy="https://images.idgesg.net/images/article/2019/06/amazon-mobile-carrier-100798159-small.3x2.jpg" alt="Amazon Mobile Carrier" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3399865/amazon-mobile-carrier.html">Why Amazon might want to be America&#039;s next mobile carrier</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3398638/google-operating-system-confusion.html">
							    <img  class="small.3x2Image  imgId100797806 " data-lazy="https://images.idgesg.net/images/article/2019/05/google-operating-system-confusion-100797806-small.3x2.jpg" alt="Google Operating System Confusion" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3398638/google-operating-system-confusion.html">Get ready for some serious Google operating system confusion</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3398486/google-assistant-transformation.html">
							    <img  class="small.3x2Image  imgId100797699 " data-lazy="https://images.idgesg.net/images/article/2019/05/google-assistant-platform-100797699-small.3x2.jpg" alt="Google Assistant Platform" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3398486/google-assistant-transformation.html">Google&#039;s grand Assistant transformation is slowly taking...</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3395480/pixel-3a-google.html">
							    <img  class="small.3x2Image  imgId100796741 " data-lazy="https://images.idgesg.net/images/article/2019/05/google-android-pixel-3-smart-phone_purple-100796741-small.3x2.jpg" alt="google android pixel 3 smart phone purple" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3395480/pixel-3a-google.html">The Pixel 3a could be Google&#039;s &#039;Moto G&#039; moment</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3391594/google-pixel-sales.html">
							    <img  class="small.3x2Image  imgId100795231 " data-lazy="https://images.idgesg.net/images/article/2019/05/google-pixel-sales-100795231-small.3x2.jpg" alt="Google Pixel Sales" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3391594/google-pixel-sales.html">The 3 big asterisks everyone&#039;s missing about Pixel sales</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3389658/lg-upgrade-letdown.html">
							    <img  class="small.3x2Image  imgId100793872 " data-lazy="https://images.idgesg.net/images/article/2019/04/lg-upgrade-letdown-100793872-small.3x2.jpg" alt="LG Upgrade Letdown" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3389658/lg-upgrade-letdown.html">LG&#039;s revolutionary upgrade letdown</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3393190/google-pixel-3a.html">
							    <img  class="small.3x2Image  imgId100795704 " data-lazy="https://images.idgesg.net/images/article/2019/05/google-pixel-3a-100795704-small.3x2.jpg" alt="Google Pixel 3a" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3393190/google-pixel-3a.html">3 burning questions about Google&#039;s Pixel 3a</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3389980/google-shift.html">
							    <img  class="small.3x2Image  imgId100794036 " data-lazy="https://images.idgesg.net/images/article/2019/04/google-shift-100794036-small.3x2.jpg" alt="Google Shift" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3389980/google-shift.html">The massive Google shift you probably haven&#039;t noticed</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3379186/android-notifications.html">
							    <img  class="small.3x2Image  imgId100791813 " data-lazy="https://images.idgesg.net/images/article/2019/03/android-notifications-100791813-small.3x2.jpg" alt="Android Notifications" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3379186/android-notifications.html">This should be the future of Android notifications</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3376164/google-hardware-pivot.html">
							    <img  class="small.3x2Image  imgId100791571 " data-lazy="https://images.idgesg.net/images/article/2019/03/google-hardware-pivot-100791571-small.3x2.jpg" alt="Google Hardware Pivot" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3376164/google-hardware-pivot.html">Making sense of Google&#039;s hardware pivot</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3341309/choose-a-smartphone.html">
							    <img  class="small.3x2Image  imgId100788728 " data-lazy="https://images.idgesg.net/images/article/2019/02/choose-a-smartphone-100788728-small.3x2.jpg" alt="Choose a Smartphone" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3341309/choose-a-smartphone.html">The smarter way to choose a smartphone</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3342453/smartphone-upgrades-downgrades.html">
							    <img  class="small.3x2Image  imgId100789374 " data-lazy="https://images.idgesg.net/images/article/2019/02/smartphone-upgrades-downgrades-100789374-small.3x2.jpg" alt="Smartphone Upgrades Downgrades" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3342453/smartphone-upgrades-downgrades.html">When did smartphone upgrades become practical downgrades?</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3342163/samsung-galaxy-fold.html">
							    <img  class="small.3x2Image  imgId100788964 " data-lazy="https://images.idgesg.net/images/article/2019/02/samsung-galaxy-fold-100788964-small.3x2.jpg" alt="Samsung Galaxy Fold" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3342163/samsung-galaxy-fold.html">Samsung Galaxy Fold: Innovation infatuation</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3336504/android-stalled-revolutions.html">
							    <img  class="small.3x2Image  imgId100786344 " data-lazy="https://images.idgesg.net/images/article/2019/01/android-pending-revolutionary-concepts-100786344-small.3x2.jpg" alt="Android Pending Revolutionary Concepts" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3336504/android-stalled-revolutions.html">Android&#039;s stalled revolutions</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3333807/android-q-notification-inbox.html">
							    <img  class="small.3x2Image  imgId100785464 " data-lazy="https://images.idgesg.net/images/article/2019/01/android-q-notification-inbox-100785464-small.3x2.jpg" alt="Android Q Notification Inbox" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3333807/android-q-notification-inbox.html">Android Q dreaming: Imagine the notification inbox</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3331896/android-trends-2019.html">
							    <img  class="small.3x2Image  imgId100745726 " data-lazy="https://images.idgesg.net/images/article/2018/01/android-trends-100745726-small.3x2.jpg" alt="Android Trends" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3331896/android-trends-2019.html">7 Android trends to watch in 2019</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3327556/5g-2019.html">
							    <img  class="small.3x2Image  imgId100782599 " data-lazy="https://images.idgesg.net/images/article/2018/12/5g-2019-100782599-small.3x2.jpg" alt="5G 2019" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3327556/5g-2019.html">5 reasons to remain skeptical about 5G in 2019</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3324487/pixel-slate-vs-pixelbook.html">
							    <img  class="small.3x2Image  imgId100781459 " data-lazy="https://images.idgesg.net/images/article/2018/11/pixel-slate-vs-pixelbook-100781459-small.3x2.jpg" alt="Pixel Slate vs Pixelbook" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3324487/pixel-slate-vs-pixelbook.html">Pixel Slate vs. Pixelbook: The productivity conundrum</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3320576/pixel-3-vs-pixel-2.html">
							    <img  class="small.3x2Image  imgId100779896 " data-lazy="https://images.idgesg.net/images/article/2018/11/pixel-3-vs-pixel-2-100779896-small.3x2.jpg" alt="Pixel 3 vs. Pixel 2" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3320576/pixel-3-vs-pixel-2.html">Pixel 3 vs. Pixel 2: Why smaller bezels aren&#039;t that big a...</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3314987/google-app-redesigns.html">
							    <img  class="small.3x2Image  imgId100778012 " data-lazy="https://images.idgesg.net/images/article/2018/10/google-app-redesigns-100778012-small.3x2.jpg" alt="Google App Redesigns" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3314987/google-app-redesigns.html">Google&#039;s app redesigns are really bumming me out</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3314617/google-enthusiastic-users.html">
							    <img  class="small.3x2Image  imgId100777014 " data-lazy="https://images.idgesg.net/images/article/2018/10/google-services-100777014-small.3x2.jpg" alt="Google Services" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3314617/google-enthusiastic-users.html">Google&#039;s most enthusiastic users have good reason to be wary</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3313346/google-pixel-slate.html">
							    <img  class="small.3x2Image  imgId100776773 " data-lazy="https://images.idgesg.net/images/article/2018/10/google-pixel-slate-100776773-small.3x2.jpg" alt="Google Pixel Slate" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3313346/google-pixel-slate.html">The Pixel Slate reality people seem to be missing</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3311474/google-pixel-3.html">
							    <img  class="small.3x2Image  imgId100776114 " data-lazy="https://images.idgesg.net/images/article/2018/10/google-pixel-3-100776114-small.3x2.jpg" alt="Google Pixel 3" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3311474/google-pixel-3.html">With the Pixel 3, Google is playing its own game</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3310248/android-ecosystem.html">
							    <img  class="small.3x2Image  imgId100775271 " data-lazy="https://images.idgesg.net/images/article/2018/10/android-apps-windows-10-100775271-small.3x2.jpg" alt="Android Apps Windows 10" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3310248/android-ecosystem.html">Android is becoming an ecosystem without borders</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3304980/google-inbox-assassination.html">
							    <img  class="small.3x2Image  imgId100771846 " data-lazy="https://images.idgesg.net/images/article/2018/09/google-inbox-app-100771846-small.3x2.jpg" alt="Google Inbox App" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3304980/google-inbox-assassination.html">The worst part about Google&#039;s Inbox assassination</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3303579/end-of-an-era-google-hardware.html">
							    <img  class="small.3x2Image  imgId100770845 " data-lazy="https://images.idgesg.net/images/article/2018/09/google-nexus-chromebook-pixel-eulogy-100770845-small.3x2.jpg" alt="Google Nexus Chromebook Pixel Eulogy" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3303579/end-of-an-era-google-hardware.html">The end of an era for Google hardware</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3302801/microsoft-swiftkey-android.html">
							    <img  class="small.3x2Image  imgId100770675 " data-lazy="https://images.idgesg.net/images/article/2018/09/microsoft-swiftkey-android-100770675-small.3x2.jpg" alt="Microsoft SwiftKey Android" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3302801/microsoft-swiftkey-android.html">Microsoft&#039;s grand SwiftKey plan is finally coming into focus</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3301540/google-smartwatch-reboot.html">
							    <img  class="small.3x2Image  imgId100770251 " data-lazy="https://images.idgesg.net/images/article/2018/08/google-wear-os-100770251-small.3x2.jpg" alt="Google Wear OS" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3301540/google-smartwatch-reboot.html">The funny thing about Google&#039;s latest smartwatch reboot</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3299024/smart-speaker-market.html">
							    <img  class="small.3x2Image  imgId100768795 " data-lazy="https://images.idgesg.net/images/article/2018/08/smart-speaker-market-100768795-small.3x2.jpg" alt="Smart Speaker Market" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3299024/smart-speaker-market.html">The fascinatingly familiar march of the smart speaker market</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3292081/fuchsia-chrome-os.html">
							    <img  class="small.3x2Image  imgId100765104 " data-lazy="https://images.idgesg.net/images/article/2018/07/fuchsia-chrome-os-100765104-small.3x2.jpg" alt="Fuchsia, Chrome OS" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3292081/fuchsia-chrome-os.html">Fuchsia, Chrome OS, and the danger of black-and-white...</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3291316/eu-android-antitrust-ruling.html">
							    <img  class="small.3x2Image  imgId100764733 " data-lazy="https://images.idgesg.net/images/article/2018/07/eu-google-android-antitrust-ruling-100764733-small.3x2.jpg" alt="EU Google Android Antitrust Ruling" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3291316/eu-android-antitrust-ruling.html">The EU&#039;s Android antitrust ruling overlooks 3 critical...</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3275786/fuchsia-android.html">
							    <img  class="small.3x2Image  imgId100758717 " data-lazy="https://images.idgesg.net/images/article/2018/05/fuchsia-android-100758717-small.3x2.jpg" alt="Fuchsia Android" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3275786/fuchsia-android.html">Fuchsia and the future of Android</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3269128/allo-google-messaging-pivot.html">
							    <img  class="small.3x2Image  imgId100755629 " data-lazy="https://images.idgesg.net/images/article/2018/04/allo-google-messaging-pivot-100755629-small.3x2.jpg" alt="Allo, Google Messaging Pivot" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3269128/allo-google-messaging-pivot.html">Allo, goodbye: The craziest thing about Google&#039;s latest...</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3267809/midrange-pixel-phone-google.html">
							    <img  class="small.3x2Image  imgId100754030 " data-lazy="https://images.idgesg.net/images/article/2018/04/midrange-pixel-phone-google-100754030-small.3x2.jpg" alt="Midrange Pixel Phone - Google - CC0 image by JosepMonter modified by JR Raphael" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3267809/midrange-pixel-phone-google.html">A midrange Pixel is probably just the tip of the iceberg</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3265051/google-is-often-its-own-worst-enemy.html">
							    <img  class="small.3x2Image  imgId100752818 " data-lazy="https://images.idgesg.net/images/article/2018/03/google-enemy-100752818-small.3x2.jpg" alt="Google Enemy" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3265051/google-is-often-its-own-worst-enemy.html">Google is often its own worst enemy</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3264429/google-amazon.html">
							    <img  class="small.3x2Image  imgId100752642 " data-lazy="https://images.idgesg.net/images/article/2018/03/google-amazon-100752642-small.3x2.jpg" alt="Google Amazon" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3264429/google-amazon.html">Google is creating its own Amazon right under our noses</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3260685/android-simplicity-spectrum.html">
							    <img  class="small.3x2Image  imgId100751545 " data-lazy="https://images.idgesg.net/images/article/2018/03/android-simplicity-100751545-small.3x2.jpg" alt="Android Simplicity" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3260685/android-simplicity-spectrum.html">Android and the shifting simplicity spectrum</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3259526/android-underdog.html">
							    <img  class="small.3x2Image  imgId100751176 " data-lazy="https://images.idgesg.net/images/article/2018/02/android-underdog-100751176-small.3x2.jpg" alt="Android Underdog" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3259526/android-underdog.html">The unlikely new Android underdog worth watching</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3252259/virtual-assistant-battle.html">
							    <img  class="small.3x2Image  imgId100749421 " data-lazy="https://images.idgesg.net/images/article/2018/02/virtual-assistant-battle-100749421-small.3x2.jpg" alt="Virtual Assistant Battle" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3252259/virtual-assistant-battle.html">What the virtual assistant battle is really all about, in a...</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3247244/post-os-era.html">
							    <img  class="small.3x2Image  imgId100746472 " data-lazy="https://images.idgesg.net/images/article/2018/01/post-os-world-100746472-small.3x2.jpg" alt="Post-OS World" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3247244/post-os-era.html">Welcome to the post-OS era</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3233300/google-ecosystem.html">
							    <img  class="small.3x2Image  imgId100739063 " data-lazy="https://images.idgesg.net/images/article/2017/10/google-ecosystem-100739063-small.3x2.jpg" alt="Google Ecosystem" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3233300/google-ecosystem.html">Welcome to the era of the Google ecosystem</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3229933/google-feed.html">
							    <img  class="small.3x2Image  imgId100737565 " data-lazy="https://images.idgesg.net/images/article/2017/10/google-feed-google-now-100737565-small.3x2.jpg" alt="Google Feed, Google Now" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3229933/google-feed.html">The Google feed has lost its soul</a>
					
					</div>
					
				</div>
			</div>
			
		
			
			
			<div class="collection-item excerpt with-img">									
					
					<div class="figure-wrapper">
						<figure class="well-img">
							<a  class="trackLink" href="/article/3159068/android-one-google.html">
							    <img  class="small.3x2Image  imgId100704591 " data-lazy="https://images.techhive.com/images/article/2017/01/android-one-google-100704591-small.3x2.jpg" alt="Android One - Google" />
							</a>
						</figure>
						
					</div>
				<div class="post-cont">
					<div class="title">
					 
					
					
						<a  class="trackLink" href="/article/3159068/android-one-google.html">How Android One could complete Google&#039;s grand Android plan</a>
					
					</div>
					
				</div>
			</div>
			
		
		</div>
</div>



<script>
	var dataLayer = window.dataLayer = window.dataLayer || [];
	dataLayer.push({
		'event': 'loadBottomCollectionModule'
		});
</script>


<script src="/www/js/video/embedder-jwp.js?v=20200708115223"></script>

<script type="text/javascript" src="/www/js/ads/jquery.lazyload-ad.js"></script>

















<script type="text/javascript">

$(document).ready(function() {
	$('.articleBloxAd').filter( ":visible" ).each(function(index, item) {
		var id = $(item).attr('id');
		var divClass = $(item).attr('class');
		var adString = IDG.GPT.getLazyAdCode();
		$(item).replaceWith("<div id=\"" + id + "\" class=\"lazyload_blox_ad " + divClass + "\">" + adString + "</div>");
	});
	try {
		$("div.lazyload_blox_ad").lazyLoadAd({
	        threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
	        forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
	        onLoad       : false,       // Callback function on call ad loading
	        onComplete   : false,       // Callback function when load is loaded
	        timeout      : 1500,        // Timeout ad load
	        debug        : false,       // For debug use : draw colors border depends on load status
	        xray         : false        // For debug use : display a complete page view with ad placements
		}) ;
	}
	catch (exception){
		console.log("error loading lazyload_ad " + exception);
	}
});

</script>
		

	
	













<style>
@media only screen and (min-width: 60.625em) {
	article .apart.ad.not-lazy {
		margin-left: 0;
		float: right;
	}
}
/* this spaces the ads in the right rail */
@media only screen and ( min-width: 48em ) {
	article #drr-top-ad.epo.cat-narrow #imu2 {
		margin-top: 400px; /*originally 354px*/
	}
	.topDeals.topper {
		margin-top: 400px;
	}
}
@media only screen and ( min-width: 48em ) and ( max-width: 58.063em ) {
	article #drr-top-ad.epo.cat-narrow #imu2 {
		margin-top: 0;
	}
}
@media only screen and ( min-width: 60.625em ) {
	article #drr-top-ad.epo.cat-narrow #imu2 {
		margin-top: 400px; /*originally 354px*/
	}
	.topDeals.topper {
		margin-top: 400px;
	}
}
@media only screen and ( min-width: 48em ) {
	article #drr-top-ad.epo.cat-narrow div[id^=imu] {
		margin-top: 400px;
	}
}
@media only screen and ( min-width: 48em ) and ( max-width: 58.063em ) {
	article #drr-top-ad.epo.cat-narrow div[id^=imu] {
		margin-top: 0;
	}
}
@media only screen and ( min-width: 60.625em ) {
	article #drr-top-ad.epo.cat-narrow div[id^=imu] {
		margin-top: 400px;
	}
}
</style>

<script type="text/javascript">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</script>		



<script>
// this debouce() function is used here and with related-content ribbon-ribbon.jsp
function debounce(func, wait, immediate){
    var timeout;
    return function(){
        var context = this, args = arguments;
        var later = function(){
            timeout = null;
            if (!immediate) func.apply(context, args);
        };
        var callNow = immediate && !timeout;
        clearTimeout(timeout);
        timeout = setTimeout(later, wait);
        if (callNow) func.apply(context, args);
    };
}

let galleryNode; // undefined if element is not found
let mobileDeviceWidth = 0;
let eventDeviceOrientation = "portrait";

if (window.innerWidth > 0) {
	mobileDeviceWidth = window.innerWidth;
} else {
	mobileDeviceWidth = document.documentElement.clientWidth;
}

if ($("figure").hasClass("thm-gallery")) {
	galleryNode = document.querySelector('.thm-gallery .embed-wrapper');
}

var supportsOrientationChange = "onorientationchange" in window,
orientationEvent = supportsOrientationChange ? "orientationchange" : "resize";

window.addEventListener(orientationEvent, function() {
	  // if device is rotated to landscape orientation
	  if (window.orientation === 90 || window.orientation === -90) {
		  eventDeviceOrientation = "landscape";
	  } else {
		  eventDeviceOrientation = "portrait";
	  }
}, false);

if (typeof galleryNode !== 'undefined') {	
	if (mobileDeviceWidth <= 480) {
		window.addEventListener('scroll', debounce(function(e) {
			// if device is rotated to landscape after page load, do not pause and play video!
			if (eventDeviceOrientation !== "landscape") {
				if (isVisible(galleryNode)) {
					jwplayer('bcplayer-gallery').play();
				} else {
			    	jwplayer('bcplayer-gallery').pause();
			  	}
			}			
		}, 5));
	}
}
</script>


	
	
	
	




					










				
			
		
		</section><!-- /.bodee -->

		














 




	
		
			
				
					











<script>var suppressEd = false;</script>

	<script>
		if (countryCode !== "" && (countryCode === 'in' || countryCode === "africa" || (brandAbbrev === "cio" && countryCode === "nz") || brandAbbrev === "cso" && countryCode === "au" )) {
			suppressEd = true;
			$("div#content-recommender").remove();
		}
	</script>







	<div id="content-recommender">
		<div class="OUTBRAIN" data-widget-id="AR_1" data-ob-template="ComputerWorld_1"></div>  
	</div>
	<script>
		var obEdition = edition ||  countryCode || '';
		var widgetId="";
		
		if (obEdition === "asean") {
			widgetId="AR_3";
			if ($("body").hasClass("slideshow")) {
				widgetId="AR_4";
			}
		}
		if (widgetId !== "") {
			$(".OUTBRAIN").attr("data-widget-id", widgetId);
		}
		
		// suppressed for certain editions
		
		if (!suppressEd) {
			$.getScript("//widgets.outbrain.com/outbrain.js");
		}
	</script>


				
				
			
			
				<div id="amazon-bottom-widget">
					<div class="amzn-custom-header">Shop Tech Products at Amazon</div>
					<div id="amazon-links" class="rr sector" original="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&storeId=httpwwwidgcsm-20&adInstanceId=270d7c31-092d-4776-a676-9f9a4f7e830f">
						<code type="text/javascript"><!--
						           console.log('lazyloaded amazon widget links in footer');
						           //-->
						</code>
					</div>
				</div>
				<script>
				$(window).load(function() {
					consent.adsel.queue.push(function(){
						try {
							$("div#amazon-links").lazyLoadAd({
						          threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
						          forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
						          onLoad       : false,       // Callback function on call ad loading
						          onComplete   : false,       // Callback function when load is loaded
						          timeout      : 2000,        // Timeout ad load
						          debug        : false,       // For debug use : draw colors border depends on load status
						          xray         : false      // For debug use : display a complete page view with ad placements
						    });
						} catch (exception){
							console.log("ERROR loading amazon widget links " + exception);
						}
					});
				});
				</script>
			
		

		
			
			
		
			
				
					<div class="lazyload_ad">
						<code type="text/javascript">
						<!--
						var slotName = 'bottomleaderboard';
						var slotSize = [];
						if ($thm.deviceClass == 'mobile') {
							slotSize = [[300,50],[320,50],[300,250]];
						}
						else if ($thm.deviceClass == 'tablet') {
							slotSize = [[728,90],[468,60]];
						}
						else {
							slotSize = [[728,90],[970,90],[970,250]];
						}
						IDG.GPT.addDisplayedAd(slotName, "true");
						document.write('<div id="' + slotName + '" class="ad-container">');
						consent.ads.queue.push(function(){
							IDG.GPT.defineGoogleTagSlot(slotName, slotSize, false, true);});
						document.write('</div>');
						consent.ads.queue.push(function(){
							$('#' + slotName).responsiveAd({screenSize:'971 1115', scriptTags: []}, true);});
						//-->
						</code>
					</div>
							
	
	



	
		
			










<link rel="stylesheet" href="/www.idgcsmb/css/tso-links.css?v=20200708115223" />

	<div id="tso-wrapper"><div id="tso" style="display:none"></div></div>
	<script type="text/javascript">
	function renderTSO(ads, requireHttps) {
		$thm.debug("renderTSO:"+ads.length);
		if (ads && ads.length > 0) {
			var selectedAds = selectTSOAds(ads,10);
			if (null != selectedAds && selectedAds.length > 0) {
				var html = "<h3>Sponsored Links</h3>";
				html += "<ul>";
				for (var i=0; i<selectedAds.length;i++) {
					html += "<li>";
					html += "<a href='"+selectedAds[i].url+"'> "+selectedAds[i].title+"</a>";
					if (null != selectedAds[i].pixel && selectedAds[i].pixel.length > 0) {
						html += selectedAds[i].pixel;
					}
					html += "</li>";
				}
				html += "</ul>";
				$("#tso").html(html).show();
			}
		}
	}
	function selectTSOAds(ads,max) {
		if (ads.length <= max) {
			return ads;
		} else {
			var uniq = {};
			var found = 0;
			var selectedAds = [];
			while (found < max) {
				var ad = ads[Math.floor(Math.random()*ads.length)];
				if (uniq[ad.id] != null) {
					continue;
				} else {
					uniq[ad.id] = true;
					found++;
					selectedAds.push(ad);
				}
			}
			return selectedAds;
		}
		return null;
	}
	</script>
	

			
		
	
	




		</article>

	</section><!-- /role=main -->

	
	
	

</div><!-- /#page-wrapper -->
		
		












	<link rel="stylesheet" href="/www.idge/css/foot.css?v=20200708115223" />
	<link rel="stylesheet" href="/www.idge.ctw/css/foot.css?v=20200708115223" />





<footer>

    <section class="brand" itemscope itemtype="http://schema.org/Organization">
   	
   		<link itemprop="url" href="http://www.computerworld.com"> 
        <a href="/"><span class="logo">Computerworld</span></a>
		<span class="tagline"> The Voice of Business Technology</span>
        
        
	        <span class="follow">
				<label>Follow us</label>
	            	<ul>
	            		














	
	
		<li class="lnkdn"><a class="social-media-li-foot" href="https://www.linkedin.com/company/computerworld" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('LinkedIn')"><i class="ss-icon ss-social-circle brand ss-linkedin"></i></a></li>
	
	
		<li><a class="social-media-tw-foot" href="https://twitter.com/computerworld" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Twitter')"><i class="ss-icon ss-social-circle ss-twitter"></i></a></li>
	
	
		<li><a class="social-media-fb-foot" href="https://www.facebook.com/Computerworld" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Facebook')"><i class="ss-icon ss-social-circle brand ss-facebook"></i></a></li>				
	
	
		<script>
			if (typeof facebookUrl !== "undefined" && facebookUrl !== null && facebookUrl !== "") {
				document.querySelector(".social-media-fb-foot").setAttribute("href", facebookUrl);
			}
			if (typeof twitterUrl !== "undefined" && twitterUrl !== null && twitterUrl != "") {
				document.querySelector(".social-media-tw-foot").setAttribute("href", twitterUrl);
			}
			if (typeof linkedInUrl !== "undefined" && linkedInUrl !== null && linkedInUrl !== "") {
					document.querySelector(".social-media-li-foot").setAttribute("href", linkedInUrl);
			} 
		</script>
	


	            	</ul>
	        </span>
        
        
    </section>
    
    
    <section class="about">
		<div class="wrapper"> 
        	<nav class="tertiary" id="ft3">
            	<ul>
            		
















<li><a class="edition-link-url" href="/about/about.html"  >About Us</a>

<li><a class="edition-link-url" href="/about/contactus.html"  >Contact</a>

<li><a class="edition-link-url" href="/about/privacy.html"  >Privacy Policy</a>

<li><a class="edition-link-url" href="/about/cookie-policy.html"  >Cookie Policy</a>

<li><a class="edition-link-url" href="/about/member-preferences.html"  >Member Preferences</a>

<li><a class="edition-link-url" href="/about/contactus.html#advertise-with-us"  >Advertising</a>

<li><a class="edition-link-url" href="https://www.idg.com/work-here/" target="_blank" rel="nofollow" >IDG Careers</a>

<li><a class="edition-link-url" href="/about/adchoices.html"  >Ad Choices</a>

<li><a class="edition-link-url" href="/about/affiliates.html"  >E-commerce Links</a>

<li><a class="edition-link-url" href="/about/ccpa.html"  >California: Do Not Sell My Personal Info</a>




            	</ul>
        	</nav>
		</div>
	</section>
	
    <section class="copyright">
        <div class="wrapper">
			
        	
        		<img src="https://alt.idgesg.net/images/logos/logo-footer-white.png" alt="IDG Communications" />
        	
        
        	
        	<p><a href="/about/copyright.html">Copyright</a> &copy; 2020 <span class="bu">IDG Communications, Inc.</span></p>
			<div class="network">
				<div id="network-selector">
                <div class="label">Explore the IDG Network <i class="ss-icon tick">descend</i></div>
                <ul>
                	
                		
                		
                	














	
		<li><a href="https://www.cio.com" target="_blank" rel="nofollow">CIO</a></li>
	
		<li><a href="https://www.computerworld.com" target="_blank" rel="nofollow">Computerworld</a></li>
	
		<li><a href="https://www.csoonline.com" target="_blank" rel="nofollow">CSO Online</a></li>
	
		<li><a href="https://www.infoworld.com" target="_blank" rel="nofollow">InfoWorld</a></li>
	
		<li><a href="https://www.networkworld.com" target="_blank" rel="nofollow">Network World</a></li>
	

                </ul>
				</div><!-- /#network-selector -->
			</div><!-- /.network -->
		</div><!-- /.wrapper -->
    </section>
</footer>


<script src="/www/js/jquery/jquery-ui.js"></script>
<script src="/www/js/jquery/jquery.dfp.min.js"></script>
<script src="/www.idge/js/mule/shortstack_nav.js"></script>




	
		
			
		





















	

		
			
			
			
			
			
			
				<div id="mobilewelcomead" class=" ad-container test">					
				</div>				
				<script type="text/javascript">
				consent.ads.queue.push(function(){
				
					IDG.GPT.addDisplayedAd("mobilewelcomead", "true");
					$('#mobilewelcomead').responsiveAd({screenSize:'971 1115', scriptTags: []});
                    IDG.GPT.log("Creating ad: mobilewelcomead - [971 1115]");
                    
				
				});
				</script>
			
		
	
 	
 
 
	




<script src="/www/js/analytics/tracking.js"></script>



	<script src="/www.idge/js/jquery/plugins/jquery.colorbox-min.js"></script>
	<script src="/www.idge/js/article.js?v=20200708115223"></script>
	
	<script src="/www.idge/js/jquery/responsive-tables.js"></script>
	<script src="/www.idge/js/jquery/jquery.tablesorter.min.js"></script>
	<script>
	$(document).ready(function() {
		$("table.tablesorter").tablesorter({
			widgets: ['zebra']
		});
		
		$("table.tablesorter tbody tr").hover(function() {
			$(this).toggleClass("selected");
		});
		
		$("table.tablesorter thead tr th").each(function(){			
			if ($(this).find('.ss-icon').length < 1) {
				$(this).append('<i class="ss-icon"></i>');
			}
		});
		
	});
	</script>
	




<script src="/www.idge/js/global.js?v=20200708115223"></script>
<script src="/www/js/webfonts/ss-social.js"></script>
<script src="/www/js/webfonts/ss-standard.js"></script>
<script src="/www/js/analytics/brandAnalytics.js"></script>
















	<script src="/www/js/locales-editions-slug.js?v=20200708115223"></script>





		
		
			
				
			





















	

		
			
			
			
			
			
			
				<div id="catfish" class=" ad-container test">					
				</div>				
				<script type="text/javascript">
				consent.ads.queue.push(function(){
				
					IDG.GPT.addDisplayedAd("catfish", "true");
					$('#catfish').responsiveAd({screenSize:'971 1115', scriptTags: []});
                    IDG.GPT.log("Creating ad: catfish - [971 1115]");
                    
				
				});
				</script>
			
		
	
 	
 
 
		
		
			
		





















	

		
			
			
				<!--  Begin gpt-skin -->
				<div id="gpt-skin" class=" ad-container">					
				</div>
				<script type="text/javascript">
				consent.ads.queue.push(function(){
					IDG.GPT.addDisplayedAd("gpt-skin", "true");
					IDG.GPT.displayGoogleTagSlot('gpt-skin');
				});
				</script>
				<!--  End gpt-skin -->	
			
			
			
			
			
		
	
 	
 
 
	


<!-- Include here when empty article and when not empty and article is slideshow as this script is included with DRR code in body-base.jsp. -->
<!-- Also do not include on search page with new right rail. OC-1778 -->



<script type="text/javascript">
// -- Load Lazy Advertisement placement as deferred
$("div.lazyload_ad").lazyLoadAd({
        threshold    : 500,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
        forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
        onLoad       : false,       // Callback function on call ad loading
        onComplete   : false,       // Callback function when load is loaded
        timeout      : 1500,        // Timeout ad load
        debug        : false,       // For debug use : draw colors border depends on load status
        xray         : false        // For debug use : display a complete page view with ad placements
}) ;
</script>







<script type='text/javascript' src="/www/js/story-nav.js"></script><script type='text/javascript' src="/www/js/utils/slick/slick.min.js"></script><script type='text/javascript'>

	var ocHead = $("#oc-head").outerHeight();
	var relatedContentHeight = $(".related-content-wrapper").outerHeight();
	relatedTop = ocHead+50;
		$(document).ready(function() {
			// moved debounce fn to body-base.jsp for use with mobile gallery script
			
			 var lastScrollTop = 0;
			 
			 if (window.addEventListener) {
		        window.addEventListener('scroll', debounce(function(e){
		        
		        var containerOffset = $("#drr-container p:last").offset().top;
			    var containerHeight = $("#drr-container p:last").outerHeight();
			    var windowHeight = $(window).height();
			    var windowScrolltop = $(this).scrollTop();

			    if (windowScrolltop > lastScrollTop) {
			    	// user is scrolling DOWN: hide ribbon
			    	$(".related-content-wrapper").css('top','-'+relatedTop+'px');
			    	
		    	 	if ((windowScrolltop > (containerOffset+containerHeight-windowHeight))&& !($('#oc-head').hasClass('no-stick-important'))) {
			    		// user is scrolling down and sees last paragraph: show ribbon
			    		$(".related-content-wrapper").css('top',ocHead+'px');
		    		}
			    	
			    } else {		        	
			    	$(".related-content-wrapper").css('top','-'+relatedTop+'px');
			    }
			   
			   	lastScrollTop = windowScrolltop;
					
		               
		        }, 5));   // run maximum of one time every 5ms
		    }
		    
		});
	

					$(document).ready(function() {
						var topper = 20;
						if ( $('body').hasClass('macworld') || $('body').hasClass('pcworld') || $('body').hasClass('techhive')) {
								topper = 0;
						}
						$(window).resize(function() { 			
							var modTocFixBegin = $("#drr-container.cat").offset().top - topper;
							var modTocFixEnd = $(".six-column").offset().top;
							var modTocStartOffsetTop = 300;
							doProductToc(true,false,modTocFixBegin,modTocFixEnd,modTocStartOffsetTop);
			
						}).resize();
					});
				

$(document).ready(function(){
		$("#collection-module-bottom .carousel-items").slick({
		lazyLoad:'ondemand',
		slidesToShow: 6,
  		slidesToScroll: 6,
		prevArrow:'<a class="prev browse left"><i class="ss-icon ss-navigateleft"></i> Previous</a>',
		nextArrow:'<a class="next browse right">Next <i class="ss-icon ss-navigateright"></i></a>',
		appendArrows: $(".carousel-nav"),
		dots: true,
		appendDots: $(".carousel-nav-nums"),
		responsive: [
		 			{
		 				breakpoint:769,
		 				settings:{
		 					slidesToShow: 4,
  							slidesToScroll: 4
		 				}
		 			},
		 			{
		 				breakpoint:512,
		 				settings: {
		 					vertical:true,
		 					slidesToShow: 6,
  							slidesToScroll: 6
		 				}
		 			}
		 		]
	});
});


	g_bRequireHttps = true;
	 	var localeId = getLocale();
		$.ajax('/ads/tso?localeId=' + localeId,{
			dataType: 'json',
			success: function(data){
				renderTSO(data.tsoLinks, g_bRequireHttps);
			},
			error: function(jqXHR,error,thrown){
				$thm.debug("TSO AJAX Status: "+error+": "+thrown,true);
			}
		});
	
</script>












	
		
	
	
		
	
	

<!-- Begin comScore Tag -->
<script>
var _comscore = _comscore || [];
_comscore.push(
{ c1: "2", c2: "6035308", c3: "", c5: "Android", c6: "Article: News Analysis", c15: "3566143" });
(function()
{
	var s = document.createElement("script"), el = document.getElementsByTagName("script")[0];
	s.async = true; s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
	el.parentNode.insertBefore(s, el);
})();
</script>
<noscript>
<img src="https://sb.scorecardresearch.com/p?c1=2&c2=6035308&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->


	<!-- LiveRamp Sources -->
	<script src="/www/js/utils/liveRamp.js"></script>
	<!-- End of LiveRamp -->













<script type="text/javascript">
consent.digitalelement.queue.push(function(){
	$thm.logPlEvent({"b":"ctw","e":"view","t":"article","id":"3566143"});
});
</script>

		<div id="loginModal"></div>
		<div id="logoffModal"></div>

		
	<script type="text/javascript">
		var subscribersSiteId = "f17ca7f3-0dbf-481a-ae3f-1042772a9095"; 
	</script>
	<script type="text/javascript" src="https://cdn.subscribers.com/assets/subscribers.js"></script>

		
		
		
		
		<script type="text/javascript">
			a=top;f=self;
			var acceptedDomains = ["lookbookhq.com"];
			var cleanedHost = a.location.hostname.split(".").slice(-2).join(".");
			if(a!=f && acceptedDomains.indexOf(cleanedHost) < 0) {
				a.location=f.location;
			}
		</script>			

		













	</body>
</html>