Skip the navigation

Adobe flaw has been used in attacks since early January

Security vendor Sourcefire says it found exploit code dating to Jan. 9 for Adobe Reader flaw

By Robert McMillan
February 23, 2009 12:00 PM ET

IDG News Service - A dangerous and unpatched vulnerability in Adobe Systems Inc.'s PDF-reading software has been around a lot longer than previously realized.

The Adobe Reader flaw, which was first reported late last week, has caused concern because the bug is easy to exploit and Adobe isn't expected to patched it for several weeks.

A vulnerability researcher at intrusion-prevention vendor Sourcefire Inc. posted a patch for the flaw on Sunday. But the unsupported patch applies only to the Windows version of Adobe Reader 9.0 and comes with no guarantees that it will actually work.

Security researchers at Symantec Corp. told Adobe about the flaw, which also affects the vendor's Acrobat software, on Feb. 12. But today, Sourcefire said an analysis of its malware database showed that attackers have been exploiting the flaw for more than six weeks.

Sourcefire has found samples of exploit code dating back to Jan. 9, said Matt Watchinski, the company's senior director of vulnerability research.

To date, the flaw has been used in small-scale attacks targeted against specific individuals, according to security researchers. Symantec, for example, said it has tracked only 100 attacks thus far. But that number has been increasing since exploit code for the flaw, which affects both Windows and Macintosh users, was made public.

Sourcefire has also posted an analysis of the flaw on its Web site, which a hacker using the name k'sOSe credited with helping him write a proof-of-concept attack that exploits the bug.

"We're starting to see more exploit code show up," said Andre DiMino, co-founder of The Shadowserver Foundation, the organization that made the first public disclosure of the flaw last Thursday.

"This developed legs last week," DiMino added in an instant message. "I think our blogging the vulnerability and Sourcefire blogging the exploit details got it going."

The vulnerability involves the way that Adobe Reader opens files that have been formatted using the JBIG data-compression algorithm. Adobe said it plans to patch the bug by March 11.

Security experts said that users can mitigate the possibility of attacks by disabling JavaScript within their Adobe software, but doing so could break corporate applications that rely on the scripting software.

Reprinted with permission from IDG.net. Story copyright 2014 International Data Group. All rights reserved.
Our Commenting Policies