Skip the navigation

Update: Older APE 'may' blue-screen Leopard upgrade, admits developer

Unsanity parses the problem, apologizes

October 28, 2007 12:00 PM ET

Computerworld - After flat-out denying on Saturday that its application-enhancement framework was responsible for blue-screening Macintoshes being upgraded to Leopard, the creator of APE hedged its bets Sunday.

"The problems some people were experiencing while doing the Mac OS X upgrade and being unable to boot due to Application Enhancer [APE] installed may have been caused by the 'old' versions not properly recognizing the system version," said Slava Karpenko, an Unsanity LLC programmer, in a post to a company blog early Sunday.

The day before, another Unsanity developer said that APE 1.5 and 1.5.1, which are more than 2 years old, "theoretically" might be involved, but seemed to dismiss the idea. Apple Inc., meanwhile, laid the blame on APE and advised users to delete the software from their machines.

Finger-pointing started Friday. Within hours of Leopard's debut, users began reporting a "blue screen of death" that appeared after running the default Upgrade option. On affected Macs, the blue screen stymied the required restart after the install, locking users out of their computers.

The Installation and Setup forum on Apple's support site was quickly flooded with messages, including one that fingered Unsanity's APE software, which is required to run Mac customizing haxies such as ShapeShifter, as the culprit. A user identified as Chris Mcculloh posted instructions on manually deleting APE using the Unix command line to kick the Mac through the restart.

Others spread Mcculloh's instructions to new threads on the Apple forum, and reports of success poured in. "This fix seemed to work perfectly for me," said another user, identified as TuHolmes.

Saturday afternoon, Unsanity said that was bunk. "APE has an artificial block implemented, so it refuses to load," said Rosyna Keller, a programmer at Unsanity. "It checks the version number and, if it is 10.5, bails. No other code is executed from APE, and at no time are any APE modules loaded." Keller claimed to have installed Leopard on three different APE-equipped Macs without problems.

"The only possible way APE could even remotely, theoretically be involved is if they are using an over 2-year-old version of APE (1.5.1 or 1.5, May 2005)," Keller said, adding that only PowerPC-based Macs could be at risk, assuming their users had not updated APE. "If they're on an ICBM [Intel chip-based Mac], this is not a possibility, as we never released an APE that was compatible with the ICBMs that did not have the system version check," he said.

On Saturday, however, Unsanity added advice to a standing compatibility note on its Web site that told users to ensure they had APE 2.0.3 or later installed before upgrading to Leopard. Karpenko repeated the recommendation Sunday. "We recommend you upgrading [sic] to 2.0.3 before upgrading your Mac OS X. It will properly detect the system version and deactivate itself," he said.



Our Commenting Policies