Millions of smart TVs, phones and routers at risk from 3-year-old flaw

smart tv

Trend Micro says up to 6.1 million devices, including this smart TV, haven't patched a software vulnerability dating from 2012.

Credit: Trend Micro

The finding highlights problems around less rigorous patching by manufacturers

A three-year-old vulnerability in a software component used in millions of smart TVs, routers and phones still hasn't been patched by many vendors, thus posing a risk, according to Trend Micro.

Although a patch was issued for the component in December 2012, Trend Micro found 547 apps that use an older unpatched version of it, wrote Veo Zhang, a mobile threats analyst.

"These are very popular apps that put millions of users in danger; aside from mobile devices, routers, and smart TVs are all at risk as well," he wrote.

There's growing concern over how manufacturers of devices such as routers and smart TVs deal with security vulnerabilities that emerge in their products. Their patching regimes are not nearly as rigorous as those from major software manufacturers, which could expose consumers to attacks as the products age.

As many as 6.1 million devices could still be vulnerable, although some companies have since updated their software, Zhang wrote.

Trend has seen attacks in the wild against devices that do not have defenses such as data execution prevention and address space layout randomization, he wrote.

"With further research, an exploit could be used not just to cause a crash, but to run arbitrary code on an affected device," he wrote. "The ability to run arbitrary code would give the attacker the ability to take control of the device, as on a PC."

The vulnerability is specifically within a code library called "libupnp" inside the Portable SDK for UPnP Devices. It is used to playback media and also for NAT (network address translation).

Of the 547 vulnerable apps, 326 are in Google's Play app store. One of the affected ones is QQMusic from Tencent, which has 100 million users in China. After being notified, Tencent released an update for the Android app on Nov. 23.

Another affected app is the Linphone SDK, which is used to incorporate VoIP into applications. It has also now been patched.

"The libupnp SDK is one of several options used by the Linphone SDK to provide NAT traversal via UPnP; if this option is chosen the vulnerable service will be activated," Zhang wrote.

Crash Course: Advanced beginner's guide to R
View Comments
Join the discussion
Be the first to comment on this article. Our Commenting Policies