Researcher slams Adobe for 'epidemic' of JavaScript bugs

Adobe fixes critical flaw in Reader, Acrobat; exploits circulating

Adobe Systems Inc. patched its free Reader and commercial Acrobat software late yesterday to plug the latest in what one researcher called an "epidemic" of JavaScript vulnerabilities in the popular programs this year.

Dubbing the bug "critical," Adobe also acknowledged reports that exploits triggering the bug are already circulating. Both the Windows and Mac editions of the Adobe software require patches.

"A critical vulnerability has been identified in Adobe Reader and Acrobat 8.1.2 and earlier versions," said the Adobe alert posted Monday. "This vulnerability would cause the application to crash and could potentially allow an attacker to take control of the affected system." Specifically, the patch plugs an input validation hole in Reader's and Acrobat's use of JavaScript, said Adobe.

Adobe Reader is the company's popular, free PDF viewer. Acrobat is Adobe's for-a-fee application for creating and managing PDF documents.

Adobe last patched JavaScript bugs in Reader and Acrobat in February, although other fixes were issued in early 2007. In February, Adobe updated both programs to Version 8.1.2 by patching nearly 30 problems. At the time, the company was criticized for not providing more information about exactly what was fixed, and why, in the 8.1.2. update.

Days later, reports surfaced that some of the JavaScript bugs patched this year had been exploited by hackers for several weeks and had infected thousands of users.

"Adobe has an epidemic with regards to JavaScript," said Andrew Storms, director of security operations at nCircle Network Security Inc., in an e-mail this morning. "With this many JavaScript bugs in Acrobat, one begins to ask questions. Why would a full, thick application like Acrobat need to be using JavaScript, especially when JavaScript in the browser has historically been a target for hackers? And since JavaScript has been a target for so many years, why hasn't Adobe flushed out these vulnerabilities already?"

According to Adobe, Versions 8.0 through 8.1.2 of both Reader and Acrobat should be patched; Reader and Acrobat 7.1.0, which were released in February, don't contain the bug and therefore don't need to be updated. Users still relying on Version 7.0.9 or earlier, however, should update to 7.1.0, urged Adobe. Reader 9 and Acrobat 9, which are expected to launch next month, are not vulnerable.

The patch can be downloaded using links in Adobe's security bulletin.

From CIO: 8 Free Online Courses to Grow Your Tech Skills
Join the discussion
Be the first to comment on this article. Our Commenting Policies