Update: Attackers exploit critical bug in Adobe's Flash, Reader

Reminiscent of July 2009 attacks that exploited same component in Reader

Adobe late Friday warned that attackers are exploiting a critical vulnerability in the company's most widely-used software: Flash Player and Adobe Reader.

The zero-day vulnerability is reminiscent of one Adobe disclosed and patched in July 2009, and comes just days after the company's head of security admitted hackers have its software in their crosshairs.

Adobe said that the bug affects Flash Player 10.0.45.2, the most up-to-date version of the popular media player, as well as older editions on Windows, Macintosh, Linux and Solaris. Also vulnerable: PDF viewer Adobe Reader 9.x and PDF creation software Adobe Acrobat 9.x on Windows, Macintosh and Unix.

Hackers are already exploiting the flaw. "There are reports that this vulnerability is being actively exploited in the wild against Flash Player, Reader and Acrobat," the company said in a security advisory issued around 3:30 p.m. PT Friday.

Danish bug tracker Secunia rated the threat as "extremely critical," the highest ranking in its five-step scoring system. The U.S. Computer Emergency Readiness Team (US-CERT), an arm of the federal Department of Homeland Security, also posted a warning of the vulnerability.

Attackers exploiting the flaw may be able to hijack the targeted computer, Adobe acknowledged.

The bug warning was almost identical to one Adobe released July 22, 2009, when it said Flash Player, Reader and Acrobat harbored a vulnerability and were under attack. Adobe patched the flaw on July 31, 2009. Some researchers claimed Adobe had known of the Flash flaw for more than half a year.

Friday's advisory noted that vulnerability exists not only inside Flash, but also within the "authplay.dll" file packaged with every Windows copy of Reader and Acrobat. That file is the interpreter that handles Flash content embedded within PDF files.

Last year, hackers exploited the bug in authplay.dll using rigged PDF documents, and also used it in drive-by attacks that enticed users into viewing malicious Flash streaming media on attack sites. Adobe gave no details Friday about the attacks it had spotted -- the first of which it received Friday morning -- but it's likely that attacks will use those same tactics.

Ironically, the newest warning came just days after Brad Arkin, Adobe's director of security and privacy, said the company is in the security spotlight, but had taken several countering steps, including emphasizing development practices that have resulted in more secure code.

Adobe did not set a timetable for shipping a patch, but earlier last week Arkin boasted that the company's security team had met a self-imposed 15-day rush patch deadline several times last year. If the company again meets that deadline, it will deliver a fix no later than June 19.

In the meantime, Reader and Acrobat users can protect themselves by deleting or renaming authplay.dll. Doing so, however, means that opening a PDF file containing Flash content will crash the software or produce an error message.

Flash Player 10.1 Release Candidate, which can be downloaded from Adobe's site, "does not appear to be vulnerable," Adobe said, implicitly urging users to shift to the unfinished software.

Gregg Keizer covers Microsoft, security issues, Apple, Web browsers and general technology breaking news for Computerworld. Follow Gregg on Twitter at @gkeizer or subscribe to Gregg's RSS feed . His e-mail address is gkeizer@ix.netcom.com.

From CIO: 8 Free Online Courses to Grow Your Tech Skills
Join the discussion
Be the first to comment on this article. Our Commenting Policies